quetz-mod_python-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Bowsher <ma...@ukf.net>
Subject 3.2.9 release blocker? API breakage for mod_python.util.Field()
Date Thu, 22 Jun 2006 16:10:55 GMT
MODPYTHON-93, r387693, backported in r393781, changes the API of
mod_python.util.Field().

I think that it would be a very bad thing to change an API in an
incompatible way in a patch release - whilst people are likely to
understand that things may break going from 3.2.x to 3.3.x, they are
quite likely to expect an upgrade *within* the 3.2.x series to be
relatively painless.

Amongst the applications broken by this, are the 0.9.x current series of
Trac releases.

I suggest un-backporting the API-breaking change from the 3.2.x
maintenance branch.

Max.





Mime
View raw message