quetz-mod_python-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Gallacher <...@jgassociates.ca>
Subject Re: [jira] Updated: (MODPYTHON-174) Update requirements to Apache 2.0.47 or greater
Date Mon, 26 Jun 2006 19:05:05 GMT
Thanks for the nudge David. I forget to change the status when I
committed the patch.

Jim

David Fraser (JIRA) wrote:
>      [ http://issues.apache.org/jira/browse/MODPYTHON-174?page=all ]
> 
> David Fraser updated MODPYTHON-174:
> -----------------------------------
> 
> 
> This is now fixed for 3.2.9 (as of rc3) so can be marked fixed...
> 
>> Update requirements to Apache 2.0.47 or greater
>> -----------------------------------------------
>>
>>          Key: MODPYTHON-174
>>          URL: http://issues.apache.org/jira/browse/MODPYTHON-174
>>      Project: mod_python
>>         Type: Task
> 
>>   Components: documentation
>>     Versions: 3.2.7, 3.2.8, 3.2.x
>>     Reporter: David Fraser
>>  Attachments: apache-2.0.47-req-doc.patch
>>
>> Usage of the apr_table_compress function requires Apache 2.0.47, but the docs only
specify version 2.0.40
>> See the following URLs for details
>> http://www.modpython.org/pipermail/mod_python/2006-February/020280.html
>> http://www.modpython.org/pipermail/mod_python/2006-May/021135.html
>> http://www.modpython.org/pipermail/mod_python/2006-May/021133.html
>> More details: apr_table_compress was was committed in r263916 to mod_python.c
>> Log message:
>> Fixed crash and memory leak in python_merge_config function in mod_python.c
>> described in MODPYTHON-75. Boyan Boyadjiev provided the code which corrected
>> the problem. This also fixes the memory leak resulting in the use of any
>> PythonOption directive as described in MODPYTHON-60.
> 


Mime
View raw message