quetz-mod_python-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Bowsher <ma...@ukf.net>
Subject Re: Trac and FieldStorage
Date Thu, 27 Jul 2006 16:02:59 GMT
Graham Dumpleton wrote:
> The outcome of incompatibilities between Trac and changes made to 
> FieldStorage in mod_python 3.2.9 resulted in us reversing out the 
> changes. The thought I expressed at the time was that we keep what 
> would be incompatible code for mod_python 3.3 on the basis that next 
> version of Trac will use WSGI as base anyway and problem will go
> away.
> 
> Problem now is that I am faced with a box which is running Trac which
> I want to try and run a snapshot of development version of mod_python
> 3.3 on. :-(
> 
> Was it concluded that it would be at all possible to modify the new 
> FieldStorage classes so they would still work in a compatible way as
> far as how Trac was using them, or was it going to be too difficult?

It is likely to be impossible (or at least, infeasibly difficult) to
remain compatible with Trac 0.9.x whilst also significantly improving
FieldStorage. Trac 0.9.x fiddles rather invasively with the FieldStorage
internals.

Perhaps you could upgrade the Trac in question to a development version
too? Trac 0.10dev is supposed to be approaching release soon, so it
would hopefully be fairly stable.

Max.


Mime
View raw message