ranger-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alok Lal <a...@hortonworks.com>
Subject Re: Code Navigation in Eclipse for Ranger project.
Date Mon, 12 Jan 2015 17:38:53 GMT
Can you clarify what did you do specifically when you say:

> When i import the project into eclipse


The following has worked for me.  After cloning the git repo, File -> Open
-> Import Existing Mavan ​Project.  And then import every project from the
list *except *the following 3:

   - The parent project ranger:range
   - winpkg
   - unixauthnative

HTH

On Mon, Jan 12, 2015 at 1:45 AM, Sitaraman Vilayannur <
vrsitaramanietflists@gmail.com> wrote:

> Hi,
>  I ran an mvn eclipse:eclipse and the build succeeded. When i import the
> project into eclipse and do a ctrl + mouseover on a function, the function
> doesnt get highlighted to enable the navigation function.  Also when i do a
> references i get a message saying "the resource is not on the build path of
> a java project".  Other projects in my Eclipse does this.   What could be
> missing? Thanks
> Sitaraman
>



-- 
"* ... there is nothing more secure then a computer which is not connected
to the network --- and powered off!...*" - from Kerberos Introduction
<http://web.mit.edu/Kerberos/www/#what_is>

-- 
CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to 
which it is addressed and may contain information that is confidential, 
privileged and exempt from disclosure under applicable law. If the reader 
of this message is not the intended recipient, you are hereby notified that 
any printing, copying, dissemination, distribution, disclosure or 
forwarding of this communication is strictly prohibited. If you have 
received this communication in error, please contact the sender immediately 
and delete it from your system. Thank You.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message