rave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ate Douma (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (RAVE-66) jstl-1.2 dependency cannot be resolved anymore from maven repository
Date Fri, 17 Jun 2011 11:26:47 GMT

    [ https://issues.apache.org/jira/browse/RAVE-66?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13050996#comment-13050996
] 

Ate Douma commented on RAVE-66:
-------------------------------

Jasha, I just tried myself with a clean repository but cannot reproduce it.
I suspect you might have retrieved a broken/corrupted or otherwise invalid pom somehow possibly
causing a wrong (or extra) dependency being pulled in.
Also be careful if you might have a maven-proxy configured which could hide other repositories
being accessed as well...
Can you check your wars WEB-INF/lib against possible suspicious jars and/or compare to the
example dist archives I provided download links for on the dev@ list yesterday?

BTW: while testing this I tried removing the java.net repository from rave-project/pom.xml
as I suspected we might not even need it (anymore?).
Which was correct, so I'll remove this superfluous maven repository which actually speeds
up a clean build considerably (~25% in my case: 9 min vs 12 min).
 

> jstl-1.2 dependency cannot be resolved anymore from maven repository
> --------------------------------------------------------------------
>
>                 Key: RAVE-66
>                 URL: https://issues.apache.org/jira/browse/RAVE-66
>             Project: Rave
>          Issue Type: Bug
>            Reporter: Marlon Pierce
>            Assignee: Ate Douma
>             Fix For: 0.1-INCUBATING
>
>
> I get the following maven error on a clean (no previous $HOME/.m2 repository) build on
linux when running mvn clean install:
> [ERROR] Failed to execute goal on project rave-portal: Could not resolve dependencies
for project org.apache.rave:rave-portal:war:0.1-incubating-SNAPSHOT: Failure to find javax.servlet:jstl:jar:1.2
in http://download.java.net/maven/2/ was cached in the local repository, resolution will not
be reattempted until the update interval of java.net has elapsed or updates are forced ->
[Help 1]
> I'm using maven 3.0.3. 
> [mpierce@gridfarm005 rave]$ java -version
> java version "1.6.0_25"
> Java(TM) SE Runtime Environment (build 1.6.0_25-b06)
> Java HotSpot(TM) 64-Bit Server VM (build 20.0-b11, mixed mode)
> [mpierce@gridfarm005 rave]$ uname -a
> Linux gridfarm005.xxx.yyy.zzz  2.6.18-238.5.1.el5 #1 SMP Mon Feb 21 05:52:39 EST 2011
x86_64 x86_64 x86_64 GNU/Linux

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message