rave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gonzalo Aguilar Delgado <gagui...@aguilardelgado.com>
Subject Re: osapi variable error
Date Fri, 21 Jun 2013 12:15:01 GMT
Hello,

It seems that the url of shinding in portal.properties was not correct. 
It's solved once I set up it correctly.

Thank you for the directions.

It should be nice if the system is error proof. Because I discovered 
that just one error in the javascript or jsp parsing and you will get an 
unusable system.

Maybe when things stabilize can get a look on how to do it.

Thanks again.


El 20/06/13 23:17, Matt Franklin escribió:
> that sounds like the shindig javascript is not getting included.  Can you
> look in the network tab of firebug or chrome debugger and see if there is
> an error retrieving it?.
>
> Also, if you are not using OpenSocial, then you need to not include
> rave_opensocial.js
>
>
> On Thu, Jun 20, 2013 at 5:10 PM, Gonzalo Aguilar Delgado <
> gaguilar@aguilardelgado.com> wrote:
>
>> Hello,
>>
>> I've just deployed a portal but found that it failed to load javascripts
>> because:
>>
>> Timestamp: 20/06/13 23:08:39
>> Error: ReferenceError: osapi is not defined
>> Source File: http://panelmahou.moviplans.**com/level2-engine/static/**
>> script/core/rave_opensocial.js<http://panelmahou.moviplans.com/level2-engine/static/script/core/rave_opensocial.js>
>> Line: 29
>>
>>
>> It's strange. But I think maven mixed two snapshots versions.
>>
>> Do you have any clue?
>>
>> Thank you.
>>


Mime
View raw message