rave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erin Noe-Payne <erin.noe.pa...@gmail.com>
Subject Re: Building with Grunt on the Angular branch
Date Mon, 29 Sep 2014 15:43:04 GMT
I also encountered the same problem.

On Mon, Sep 29, 2014 at 8:54 AM, Matt Franklin <m.ben.franklin@gmail.com> wrote:
> On Mon, Sep 29, 2014 at 10:31 AM, Stanton Sievers <ssievers@apache.org>
> wrote:
>
>> Hi everyone,
>>
>> I've been playing around with the Angular branch trying to get the new work
>> up and running but I've run into some problems.
>>
>> From what I can tell, all I need to do is run "npm install" (first time
>> only) and then "grunt dev" to build everything.  If I follow those simple
>> steps I end up getting less build errors:
>>
>> > Running "less:dev" (less) task
>> > >> 'bootstrap/less/bootstrap.less' wasn't found.
>> > Warning: Error compiling LESS. Use --force to continue.
>> >
>> > Aborted due to warnings.
>>
>> I can work around these issues by updating the paths in "rave.less" to use
>> the proper relative path to the boostrap resources in
>> rave-portal-resources.
>>
>> At that point, things build but do not run when I go to "
>> http://0.0.0.0:8080"
>> I get an error related to this line in "index.html":
>> > <script data-main='config/startup', src='requirejs/require.js'></script>
>>
>> That file does not exist.
>>
>> I feel like I'm missing something at a high-level here.  Has anyone had
>> luck getting things to run from the angular branch
>
>
> I am seeing the same issues.  Maybe the submitters of that code patch can
> shine some light on the equation.
>
>
>> ?
>>
>> Thanks,
>> -Stanton
>>

Mime
View raw message