rocketmq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ROCKETMQ-208) incompatibility problem found in enviroment of JDK 1.7 when running client
Date Mon, 03 Jul 2017 06:14:01 GMT

    [ https://issues.apache.org/jira/browse/ROCKETMQ-208?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16071961#comment-16071961
] 

ASF GitHub Bot commented on ROCKETMQ-208:
-----------------------------------------

Github user Jaskey closed the pull request at:

    https://github.com/apache/incubator-rocketmq/pull/110


> incompatibility problem found in enviroment of JDK 1.7 when running client
> --------------------------------------------------------------------------
>
>                 Key: ROCKETMQ-208
>                 URL: https://issues.apache.org/jira/browse/ROCKETMQ-208
>             Project: Apache RocketMQ
>          Issue Type: Bug
>          Components: rocketmq-client
>         Environment: jdk  1.7
>            Reporter: laiyiyu
>            Assignee: Jaskey Lam
>             Fix For: 4.1.0-incubating
>
>
> when I start the application which dependencies on rmq client 3.5.8  in  java7, the application
throw the exception no such method, causing by the ConcurrentHashMap inner class KeySetView
 of the   java8    incompatible with  the java7;
> so , I think the official use the   java8 packing the rmq  source code



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message