roller-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Raible (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ROL-1910) Search doesn't work after upgrading from Roller 4 to Roller 5, RC4
Date Mon, 21 Mar 2011 16:59:05 GMT

    [ https://issues.apache.org/jira/browse/ROL-1910?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13009204#comment-13009204
] 

Matt Raible commented on ROL-1910:
----------------------------------

I added DEBUG on that package by adding the following in $CATALINA_HOME/lib/roller-custom.properties:

log4j.logger.org.apache.roller.weblogger.business.search.operations=DEBUG

All I see is the following every couple minutes:

DEBUG 2011-03-21 10:15:59,893 IndexManagerImpl:executeIndexOperationNow - Executing index
operation now: org.apache.roller.weblogger.business.search.operations.SearchOperation

If I do it locally, it seems to work fine:

INFO  2011-03-21 10:19:04,568 PreviewServlet:init - Initializing PreviewServlet
DEBUG 2011-03-21 10:19:06,228 RebuildWebsiteIndexOperation:doRun - Entries to index: 3243
DEBUG 2011-03-21 10:19:06,545 RebuildWebsiteIndexOperation:doRun - Indexed entry 3/2/11 12:11
AM: the_greatest_snow_on_earth
DEBUG 2011-03-21 10:19:06,630 RebuildWebsiteIndexOperation:doRun - Indexed entry 2/28/11 2:08
PM: fixing_xss_in_jsp_2
DEBUG 2011-03-21 10:19:06,681 RebuildWebsiteIndexOperation:doRun - Indexed entry 2/25/11 3:14
PM: upcoming_conferences_tssjs_in_las
DEBUG 2011-03-21 10:19:06,754 RebuildWebsiteIndexOperation:doRun - Indexed entry 2/23/11 4:55
PM: implementing_ajax_authentication_using_jquery
DEBUG 2011-03-21 10:19:06,807 RebuildWebsiteIndexOperation:doRun - Indexed entry 2/11/11 3:54
PM: integration_testing_with_http_https
DEBUG 2011-03-21 10:19:06,962 RebuildWebsiteIndexOperation:doRun - Indexed entry 2/10/11 4:53
PM: implementing_extensionless_urls_with_tapestry
DEBUG 2011-03-21 10:19:07,006 RebuildWebsiteIndexOperation:doRun - Indexed entry 2/1/11 5:57
PM: crested_butte
DEBUG 2011-03-21 10:19:07,092 RebuildWebsiteIndexOperation:doRun - Indexed entry 1/28/11 3:47
PM: alta

The major difference b/w the two installations is JSPWiki is working on my production site.
That JSP Wiki plugin seems to require lucene-1.4.3.jar, while Roller requires lucene-core-2.9.0.jar.
If I remove lucene-1.4.3.jar, I get the following error:

INFO: No jspwiki.propertyfile defined for this context, using default from /WEB-INF/jspwiki.properties
Exception in thread "Thread-32" java.lang.NoSuchMethodError: org.apache.lucene.document.Field.Keyword(Ljava/lang/String;Ljava/lang/String;)Lorg/apache/lucene/document/Field;
        at com.ecyrd.jspwiki.search.LuceneSearchProvider.luceneIndexPage(LuceneSearchProvider.java:437)
        at com.ecyrd.jspwiki.search.LuceneSearchProvider.doFullLuceneReindex(LuceneSearchProvider.java:191)
        at com.ecyrd.jspwiki.search.LuceneSearchProvider.access$000(LuceneSearchProvider.java:70)
        at com.ecyrd.jspwiki.search.LuceneSearchProvider$1.run(LuceneSearchProvider.java:352)
        at java.lang.Thread.run(Thread.java:619)

Unfortunately, removing this old JAR still doesn't seem to solve the problem.



> Search doesn't work after upgrading from Roller 4 to Roller 5, RC4
> ------------------------------------------------------------------
>
>                 Key: ROL-1910
>                 URL: https://issues.apache.org/jira/browse/ROL-1910
>             Project: Roller
>          Issue Type: Bug
>          Components: Search
>    Affects Versions: 5.0
>            Reporter: Matt Raible
>            Assignee: Roller Unassigned
>             Fix For: 5.0
>
>
> See http://raibledesigns.com/rd/entry/upgraded_to_apache_roller_5

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message