roller-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Johnson (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ROL-2123) Make changes necessary to compile and run on Java 11
Date Sat, 27 Oct 2018 21:32:00 GMT

    [ https://issues.apache.org/jira/browse/ROL-2123?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16658310#comment-16658310
] 

David Johnson edited comment on ROL-2123 at 10/27/18 9:31 PM:
--------------------------------------------------------------

java11 branch now builds but does not run with Java 11. We need Guice and Struts 2 support
for Java 11. Changes are here: [https://github.com/apache/roller/compare/master...java11] 


was (Author: djohnson):
java11 branch now builds and runs with Java 11, but some clean-up is needed before merge.

Changes are here: [https://github.com/apache/roller/compare/master...java11] 

> Make changes necessary to compile and run on Java 11
> ----------------------------------------------------
>
>                 Key: ROL-2123
>                 URL: https://issues.apache.org/jira/browse/ROL-2123
>             Project: Apache Roller
>          Issue Type: Improvement
>          Components: Data Model &amp; JPA Backend
>            Reporter: David Johnson
>            Assignee: David Johnson
>            Priority: Major
>
> Make changes necessary for Roller to compile and run on Java 10 and 11.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message