samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Riccomini <criccom...@apache.org>
Subject Re: NoSuchMethodError
Date Mon, 16 Mar 2015 16:56:13 GMT
Hey Jordi,

The stack trace you've pasted suggests that you're missing Scala in the
classpath, or have a different version of Scala in the classpath than what
Samza was compiled with.

You should not be manually assembling the dependencies for your job. Your
build system should be doing this for you. Please see hello-samza's pom.xml:

  https://github.com/apache/samza-hello-samza/blob/master/pom.xml

For an example of how to do this. Specifically, the "assembly" plugin in
Maven is used to build a .tgz file for your job, which has all of its
required components:

  http://maven.apache.org/plugins/maven-assembly-plugin/

If you're not using Maven, Gradle and SBT can both assemble .tgz files as
well.

Cheers,
Chris

On Mon, Mar 16, 2015 at 4:11 AM, Jordi Blasi Uribarri <jblasi@nextel.es>
wrote:

> Hello,
>
> I am new to Samza and I am trying to test it. I have not found much
> documentation and I am not sure if this is the correct place for this kind
> of questions. Please let me know if I am in the wrong place. I have tried
> to follow the documentation but I guess I missed something or  did
> something wrong.
>
> I have installed a clean debian box and followed the instructions to
> download and build from git.
>
> git clone http://git-wip-us.apache.org/repos/asf/samza.git
> cd samza
> ./gradlew clean build
>
> I have also installed scala (2.9.2 ) and java 7 jdk an jre.
>
> I have created a simple job in java and I am trying to run it but I am
> seeing some java dependencies problems when I try to run both run-job.sh
> and run-am.sh scripts.
>
> What I have done is create a folder for the jobs in /opt/jobs. There I
> have created a bin folder for the scripts and a lib folder for all the jars
> that I find that are required (as I have seen in the script that this the
> place where they are obtained). I have copied there all the jar contained
> in the samza folders and the ones I have obtained from a hadoop-2.6.0
> instalation package. Some of the dependencies have been solved but I am
> stuck in the following error when I run run-am.sh:
>
> Exception in thread "main" java.lang.NoSuchMethodError:
> scala.Predef$.augmentString(Ljava/lang/String;)Ljava/lang/String;
>         at
> org.apache.samza.job.yarn.SamzaAppMaster$$anonfun$main$3.apply(SamzaAppMaster.scala:63)
>         at
> org.apache.samza.job.yarn.SamzaAppMaster$$anonfun$main$3.apply(SamzaAppMaster.scala:63)
>         at org.apache.samza.util.Logging$class.info(Logging.scala:55)
>         at
> org.apache.samza.job.yarn.SamzaAppMaster$.info(SamzaAppMaster.scala:55)
>         at
> org.apache.samza.job.yarn.SamzaAppMaster$.main(SamzaAppMaster.scala:63)
>         at
> org.apache.samza.job.yarn.SamzaAppMaster.main(SamzaAppMaster.scala)
>
> What I am missing?
>
> As a more general question, I am having quite a work compiling the
> dependencies. Is there a reference of the jar files needed for the jobs and
> scripts to run correctly?
>
> thanks for your help,
>
>                 Jordi
> ________________________________
> Jordi Blasi Uribarri
> Área I+D+i
>
> jblasi@nextel.es
> Oficina Bilbao
>
> [http://www.nextel.es/wp-content/uploads/Firma_Nextel_2014.png]
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message