samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yi Pan <nickpa...@gmail.com>
Subject Library version conflict issues
Date Thu, 21 May 2015 01:13:43 GMT
Hi, all,

Just curious about one thing:
- Samza as a platform brings in a set of dependency libraries
- Applications developed in Samza may bring in other libraries that
conflicts w/ the Samza libraries (we have got one use case that requires
jackson 1.4.2 which conflicts with jackson 1.8.5 that Samza is using
currently).

There are many possible ways to allow different versions of the same
libraries live within the same application: e.g. allow installation of jars
into different class paths and use multiple class loaders to load jars that
requires different versions of the same library.

In general, I am curious how and whether Samza should recommend a guideline
for this kind of issue? Any folks in the community already dealing with it?

Thanks!

-Yi

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message