samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Navina Ramesh <nram...@linkedin.com>
Subject Re: Checkpoint tool not working
Date Fri, 30 Oct 2015 21:45:27 GMT
Hi Lucas,

What is the format that you are using for re-specifying the offsets? Do you
specify it with --new-offsets ?

If you can share that, it will be great. It seems to work for me.

Thanks!
Navina

On Fri, Oct 30, 2015 at 9:11 AM, Roger Hoover <roger.hoover@gmail.com>
wrote:

> I tried it once with 0.9.1 and it didn't work for me either.  I didn't have
> time to examine it more carefully at the time.
>
> Roger
>
> On Thu, Oct 29, 2015 at 10:05 PM, Lukas Steiblys <lukas@doubledutch.me>
> wrote:
>
> > I'm using Samza 0.9.1.
> >
> > Lukas
> >
> > On 10/29/15, Yi Pan <nickpan47@gmail.com> wrote:
> > > Hi, Lukas,
> > >
> > > Which version of checkpoint-tool are you using?
> > >
> > > -Yi
> > >
> > > On Thu, Oct 29, 2015 at 5:39 PM, Lukas Steiblys <lukas@doubledutch.me>
> > > wrote:
> > >
> > >> Hello,
> > >>
> > >> I’m trying to write the checkpoints for a Samza task supplying these
> > >> arguments to the checkpoint tool:
> > >>
> > >> bin/checkpoint-tool.sh
> > >> --new-offsets=file:///checkpoints/client-metrics.properties
> > >> --config-path=file:///checkpoints/task.properties
> > >>
> > >> However, it doesn’t actually write the checkpoints and, instead,
> prints
> > >> out the current checkpoints.
> > >>
> > >> Is the tool currently broken? A sample of the
> client-metrics.properties
> > >> file:
> > >>
> > >> tasknames.Partition 13.systems.kafka.streams.Sessions.partitions.13 =
> > >> 7233333
> > >> tasknames.Partition 14.systems.kafka.streams.Sessions.partitions.14 =
> > >> 14589258
> > >> tasknames.Partition
> > >> 15.systems.kafka.streams.Sessions.partitions.15=10886881
> > >>
> > >> Lukas
> > >
> >
>



-- 
Navina R.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message