samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yi Pan <nickpa...@gmail.com>
Subject Re: Same error when using an ubuntu (15.10) image
Date Thu, 14 Jan 2016 17:58:31 GMT
Here is the line from the tutorial:
{noformat}

NOTE: if you are building from the latest branch of hello-samza project,
make sure that you run the following step from your local Samza project
first:

./gradlew publishToMavenLocal

Then, you can continue w/ the following command in hello-samza project:

mvn clean package
mkdir -p deploy/samza
tar -xvf ./target/hello-samza-0.10.0-dist.tar.gz -C deploy/samza

{noformat}

On Thu, Jan 14, 2016 at 9:54 AM, Yi Pan <nickpan47@gmail.com> wrote:

> Hi, Christian,
>
> Which local directory are you running ./gradlew publishToMavenLocal from?
> The command needs to be executed from the directory under which the Samza
> project is checked out, *not* where the hello-samza project is checked out.
>
> -Yi
>
> On Thu, Jan 14, 2016 at 7:53 AM, Christian Kniep <ckniep@gaikai.com>
> wrote:
>
>> Hey guys,
>>
>> to rules out that my OS choice had a big effect I followed the steps on
>> the tutorial and created an ubuntu version.
>> The README provides my step in detail: https://github.com/qnib/u-samza
>>
>> I was not able to execute the gradlew command, maybe that’s my problem?
>>
>> Furthermore, when installed via grid - how are the services ZK, kafka and
>> yarn are started - the documentation might elaborate a bit on this to help
>> rockies out.
>>
>> Cheers
>> Christian
>>
>>
>>
>> --
>>
>>
>>
>> Christian Kniep  |  Release Engineer
>>
>> www.gaikai.com
>>
>>
>

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message