samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yi Pan \(Data Infrastructure\) via Review Board" <nore...@reviews.apache.org>
Subject Re: Review Request 43244: support elasticsearch version 2.x
Date Thu, 20 Apr 2017 08:24:12 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43244/#review172454
-----------------------------------------------------------


Ship it!




Ship It!

- Yi Pan (Data Infrastructure)


On Feb. 5, 2016, 8:19 a.m., Jiri Humpolicek wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/43244/
> -----------------------------------------------------------
> 
> (Updated Feb. 5, 2016, 8:19 a.m.)
> 
> 
> Review request for samza.
> 
> 
> Repository: samza
> 
> 
> Description
> -------
> 
> Samza elasticsearch system doesn't support elastic search 2.x because of breaking changes
in java API: https://www.elastic.co/guide/en/elasticsearch/reference/current/breaking_20_java_api_changes.html
. It will be nice to support that.
> 
> 
> Diffs
> -----
> 
>   gradle/dependency-versions.gradle 52e25aa 
>   samza-elasticsearch/src/main/java/org/apache/samza/system/elasticsearch/client/NodeClientFactory.java
0ee9e3f 
>   samza-elasticsearch/src/main/java/org/apache/samza/system/elasticsearch/client/TransportClientFactory.java
7f8f3f3 
>   samza-elasticsearch/src/test/java/org/apache/samza/system/elasticsearch/indexrequest/DefaultIndexRequestFactoryTest.java
61c3e7d 
> 
> 
> Diff: https://reviews.apache.org/r/43244/diff/1/
> 
> 
> Testing
> -------
> 
> It works for me with elastic search 2.1
> 
> 
> Thanks,
> 
> Jiri Humpolicek
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message