samza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Malcolm McFarland <mmcfarl...@cavulus.com>
Subject Samza tasks aren't starting in YARN containers
Date Tue, 07 May 2019 22:22:55 GMT
Hey folks,

We're having some trouble running Samza under YARN. The YARN
containers are launching fully into the RUNNING state, and I can see
in the node manager logs that the containers are running, but my logs
are showing that Samza is not actually starting inside of the
container. What's really curious is that this is intermittent;
everything will launch fine one time, and then it will do this
RUNNING-but-no-Samza thing the next.

I've been trying to get into the AM UI to see what's going on, but I
see the following error when I try accessing it:

Problem accessing /proxy/application_1557265340810_0002/. Reason:
    Cannot assign requested address (Bind failed)
Caused by:
java.net.BindException: Cannot assign requested address (Bind failed)

Has anybody seen this issue with the AM web interface? Also, are there
any other ways that I could introspect the YARN container to try and
deduce what's happening?

Cheers,
Malcolm


-- 
Malcolm McFarland
Cavulus


This correspondence is from HealthPlanCRM, LLC, d/b/a Cavulus. Any
unauthorized or improper disclosure, copying, distribution, or use of
the contents of this message is prohibited. The information contained
in this message is intended only for the personal and confidential use
of the recipient(s) named above. If you have received this message in
error, please notify the sender immediately and delete the original
message.

Mime
View raw message