sentry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tuong Truong (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SENTRY-338) Sentry policy import tool adds non-compatible comments to grant privilege statements
Date Wed, 23 Jul 2014 16:21:38 GMT

     [ https://issues.apache.org/jira/browse/SENTRY-338?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tuong Truong updated SENTRY-338:
--------------------------------

    Fix Version/s:     (was: 1.4.0)
                   1.5.0

> Sentry policy import tool adds non-compatible comments to grant privilege statements
> ------------------------------------------------------------------------------------
>
>                 Key: SENTRY-338
>                 URL: https://issues.apache.org/jira/browse/SENTRY-338
>             Project: Sentry
>          Issue Type: Bug
>    Affects Versions: 1.4.0
>            Reporter: Prasad Mujumdar
>            Assignee: Ashish Kumar Singh
>             Fix For: 1.5.0
>
>
> The policy file to SQL tool generates grant statements with inline comments prefixed
with '#'. 
> For example, 
> {noformat}
> GRANT ALL ON TABLE tab1 TO ROLE junior_analyst_role; # server=server1, database=default
> {noformat}
> Beeline doesn't support that syntax and fails to execute the script.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message