sentry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregory Chanan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SENTRY-397) e2e UnitTests of SENTRY can't run on JDK 1.6
Date Wed, 20 Aug 2014 17:28:27 GMT

    [ https://issues.apache.org/jira/browse/SENTRY-397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14104162#comment-14104162
] 

Gregory Chanan commented on SENTRY-397:
---------------------------------------

Later versions of Apache Solr (4.5+?) don't work against JDK6.  Sentry needs a version with
the MiniSolrCloudCluster, which in Apache Solr is only 4.8+.  If you want to test against
JDK6, you can use a version of Solr that supports both, e.g. 4.4.0-cdh5.1.0.

> e2e UnitTests of SENTRY can't run on JDK 1.6
> --------------------------------------------
>
>                 Key: SENTRY-397
>                 URL: https://issues.apache.org/jira/browse/SENTRY-397
>             Project: Sentry
>          Issue Type: Bug
>            Reporter: Dapeng Sun
>            Priority: Critical
>
> # For {{sentry-test-solr}}
> It will failed like these
> {noformat}
> -------------------------------------------------------
>  T E S T S
> -------------------------------------------------------
> -------------------------------------------------------
>  T E S T S
> -------------------------------------------------------
> Results :
> Tests run: 0, Failures: 0, Errors: 0, Skipped: 0
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 11.275s
> [INFO] Finished at: Wed Aug 20 16:24:03 CST 2014
> [INFO] Final Memory: 32M/1931M
> [INFO] ------------------------------------------------------------------------
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.16:test
(default-test) on project sentry-tests-solr: Execution default-test of goal org.apache.maven.plugins:maven-surefire-plugin:2.16:test
failed: java.lang.UnsupportedClassVersionError: org/apache/solr/client/solrj/SolrRequest :
Unsupported major.minor version 51.0; nested exception is java.lang.UnsupportedClassVersionError:
org/apache/solr/client/solrj/SolrRequest : Unsupported major.minor version 51.0 -> [Help
1]
> [ERROR] 
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR] 
> [ERROR] For more information about the errors and possible solutions, please read the
following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginExecutionException
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message