sentry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prasad Mujumdar (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SENTRY-490) Schema upgrade tool tries to set incompatible isolation level for some backend DBs
Date Sat, 04 Oct 2014 03:06:34 GMT
Prasad Mujumdar created SENTRY-490:
--------------------------------------

             Summary: Schema upgrade tool tries to set incompatible isolation level for some
backend DBs
                 Key: SENTRY-490
                 URL: https://issues.apache.org/jira/browse/SENTRY-490
             Project: Sentry
          Issue Type: Bug
    Affects Versions: 1.4.0
            Reporter: Prasad Mujumdar


For some backend DB like Oracle, the upgrade tool reports error in changing isolation level.
The upgrade itself works fine though. We need to fix the way default isolation level is set.

{noformat}
...
Connecting to jdbc:oracle:thin:@//sentry-7.vpc.cloudera.com:1521/xe
Connected to: Oracle (version Oracle Database 11g Express Edition Release 11.2.0.2.0 - 64bit
Production)
Driver: Oracle JDBC driver (version 11.2.0.2.0)
Error: READ_COMMITTED and SERIALIZABLE are the only valid transaction levels (state=99999,code=17030)
Autocommit status: true
{noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message