sentry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dapeng Sun (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SENTRY-770) When use sentry to configuration hive,to ensure safety of data access.The functions(row_number and unbase64) can't be used.The Problem caused by a sentry bug. I have already found a way to solve the problem,except to modify the sentry source code.
Date Thu, 11 Jun 2015 11:55:01 GMT

     [ https://issues.apache.org/jira/browse/SENTRY-770?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dapeng Sun resolved SENTRY-770.
-------------------------------
    Resolution: Duplicate

> When use sentry to configuration hive,to ensure safety of data access.The functions(row_number
and unbase64) can't be used.The Problem caused by a sentry bug. I have already found a way
to solve the problem,except to modify the sentry source code.
> -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: SENTRY-770
>                 URL: https://issues.apache.org/jira/browse/SENTRY-770
>             Project: Sentry
>          Issue Type: Bug
>          Components: Hive Plugin
>    Affects Versions: 1.4.0, 1.5.0
>            Reporter: jingyingHu
>              Labels: documentation
>             Fix For: 1.5.0, 1.4.0
>
>
> When use sentry to configuration hive,to ensure safety of data access.The functions(row_number
and unbase64) can't be used.The Problem caused by a sentry bug. This bug is also in the lastest
version apache-sentry-1.5.0-incubating-src.tar.gz.
> The Error Found In That the hiveserver2 Log Print Is Below:
> [Hive Server2-Handler-Pool': Thread-19]: ERROR ql.Driver: FAILED: SemanticException No
valid privileges
>  Required privileges for this query:
> org.apache.hadoop.hive.ql.parse.SemanticException: No vaild privileges
>  Required privileges for this query:
>         at org.apache.sentry.binding.hive.HiveAuthzBindingHook.postAnalyze(HiveAuthzBindingHook.java:342)
>         at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:440)
>         at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:335)
> ......
> ......
> ......
> Caused by: org.apache.hadoop.hive.ql.metadata.AuthorizationException: The UDF unbase64
is not found in the list of allowed UDFs
>         at org.apache.sentry.binding.hive.HiveAuthzBindingHook.checkUDFWhiteList(HiveAuthzBindingHook.java:556)
>         at org.apache.sentry.binding.hive.HiveAuthzBindingHook.authorizeWithHiveBindings(HiveAuthzBindingHook.java:454)
>         at org.apache.sentry.binding.hive.HiveAuthzBindingHook.postAnalyze(HiveAuthzBindingHook.java:332)
>         ... 33 more



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message