serf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko ─îibej <br...@apache.org>
Subject Re: [patch] create_certs.py compatibility with pyOpenSSL >= 17.1.0
Date Fri, 26 Oct 2018 12:25:21 GMT
On 24.10.2018 05:20, James McCoy wrote:
> Starting in 17.1.0, the OpenSSL.crypto.CRL.export() fuction requires the
> caller to specify the digest type, after a few years of not specifying
> one being a deprecation warning.  Since this is just used for tests, I
> kept the old default of md5.

On the lastest macOS, which ships with Python 2.7.10 and pyopenssl 0.13.1:

TypeError: 'digest' is an invalid keyword argument for this function

But it works without the patch. This should be checking the version of
pyopenssl, I think.

-- Brane


Mime
View raw message