servicemix-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From chir...@apache.org
Subject svn commit: r669949 - /servicemix/components/components-pom/trunk/pom.xml
Date Fri, 20 Jun 2008 15:40:58 GMT
Author: chirino
Date: Fri Jun 20 08:40:58 2008
New Revision: 669949

URL: http://svn.apache.org/viewvc?rev=669949&view=rev
Log:
All components are now building as part of the reactor build

Modified:
    servicemix/components/components-pom/trunk/pom.xml

Modified: servicemix/components/components-pom/trunk/pom.xml
URL: http://svn.apache.org/viewvc/servicemix/components/components-pom/trunk/pom.xml?rev=669949&r1=669948&r2=669949&view=diff
==============================================================================
--- servicemix/components/components-pom/trunk/pom.xml (original)
+++ servicemix/components/components-pom/trunk/pom.xml Fri Jun 20 08:40:58 2008
@@ -45,6 +45,7 @@
 
   <modules>
     <module>shared-libraries</module>
+
     <module>bindings/servicemix-cxf-bc</module>
     <module>bindings/servicemix-file</module>
     <module>bindings/servicemix-ftp</module>
@@ -53,14 +54,12 @@
     <module>bindings/servicemix-mail</module>
     <module>bindings/servicemix-truezip</module>
     <module>bindings/servicemix-xmpp</module>
+
     <module>engines/servicemix-bean</module>
-<!--
     <module>engines/servicemix-camel</module>
     <module>engines/servicemix-cxf-se</module>
     <module>engines/servicemix-drools</module>
--->
     <module>engines/servicemix-eip</module>
-<!--
     <module>engines/servicemix-jsr181</module>
     <module>engines/servicemix-osworkflow</module>
     <module>engines/servicemix-quartz</module>
@@ -69,7 +68,6 @@
     <module>engines/servicemix-scripting</module>
     <module>engines/servicemix-validation</module>
     <module>engines/servicemix-wsn2005</module>
--->
   </modules>
 
   <properties>
@@ -97,38 +95,6 @@
     <!-- Tooling -->    
     <jbi-maven-plugin-version>3.2.1</jbi-maven-plugin-version>
     
-    <!-- 
-      We should work on moving these dependencies down into the component poms.. 
-      leaving commented to that components can cut and paste their dependencies 
-      more easily.
-    -->
-    <!--
-    <servicemix-version>3.2.1</servicemix-version>
-
-    <cxf-version>2.1.1-SNAPSHOT</cxf-version>
-    <activemq-version>5.1.0</activemq-version>
-
-    <xbean-version>3.4.1</xbean-version>
-    <jetty-version>6.1.6</jetty-version>
-
-    <xfire-jsr181-api-version>1.0-M1</xfire-jsr181-api-version>
-    <xfire-version>1.2.5</xfire-version>
-    <mavenAssemblyPluginVersion>2.1</mavenAssemblyPluginVersion>
-    <activeio-version>3.1.0</activeio-version>
-    <backport-util-concurrent-version>2.2</backport-util-concurrent-version>
-    <camel-version>1.3.0</camel-version>
-    <jencks-version>2.1</jencks-version>
-    <geronimo-version>2.0.1</geronimo-version>
-    <commons-beanutils-version>1.7.0</commons-beanutils-version>
-    <commons-fileupload-version>1.1.1</commons-fileupload-version>
-    <msv-version>20050913</msv-version>
-    <oro-version>2.0.8</oro-version>
-    <sitemesh-version>2.2.1</sitemesh-version>
-    <woden-version>1.0.0M6</woden-version>
-    <derby-version>10.2.2.0</derby-version>
-    <saxon-version>8.9</saxon-version>
-    -->
-
     <servicemix.osgi.export>${servicemix.osgi.export.pkg}*;version=${project.version}</servicemix.osgi.export>
     <servicemix.osgi.export.pkg>org.apache.servicemix</servicemix.osgi.export.pkg>
     <servicemix.osgi.import>*</servicemix.osgi.import>
@@ -137,1347 +103,201 @@
   </properties>
   
   <dependencyManagement>
-    <dependencies>
-      
-      <!-- Keep the most common dependencies here to help avoid conflicts across components -->
-      <!-- But if we put too much stuff here we will have to release this pom often, since we would need
-           a release every time a dependency changes -->
-      <dependency>
-        <groupId>commons-logging</groupId>
-        <artifactId>commons-logging</artifactId>
-        <version>${commons-logging-version}</version>
-        <optional>true</optional>
-        <scope>provided</scope>
-        <exclusions>
-          <exclusion>
-            <groupId>avalon-framework</groupId>
-            <artifactId>avalon-framework</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>logkit</groupId>
-            <artifactId>logkit</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>javax.servlet</groupId>
-            <artifactId>servlet-api</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      
-      <dependency>
-        <groupId>org.springframework</groupId>
-        <artifactId>spring</artifactId>
-        <version>${spring-version}</version>
-        <scope>provided</scope>
-      </dependency>
-      <dependency>
-        <groupId>org.springframework</groupId>
-        <artifactId>spring-support</artifactId>
-        <version>${spring-version}</version>
-        <scope>provided</scope>
-      </dependency>
-      <dependency>
-        <groupId>org.springframework</groupId>
-        <artifactId>spring-aop</artifactId>
-        <version>${spring-version}</version>
-        <scope>provided</scope>
-      </dependency>
-      <dependency>
-        <groupId>org.springframework</groupId>
-        <artifactId>spring-jmx</artifactId>
-        <version>${spring-version}</version>
-        <scope>provided</scope>
-      </dependency>
-      <dependency>
-        <groupId>org.springframework</groupId>
-        <artifactId>spring-context</artifactId>
-        <version>${spring-version}</version>
-        <scope>provided</scope>
-      </dependency>
-      <dependency>
-        <groupId>org.springframework</groupId>
-        <artifactId>spring-beans</artifactId>
-        <version>${spring-version}</version>
-        <scope>provided</scope>
-      </dependency>
-      <dependency>
-        <groupId>org.springframework</groupId>
-        <artifactId>spring-core</artifactId>
-        <version>${spring-version}</version>
-        <scope>provided</scope>
-      </dependency>
-
-      <dependency>
-        <groupId>stax</groupId>
-        <artifactId>stax-api</artifactId>
-        <version>${stax-api-version}</version>
-        <scope>provided</scope>
-      </dependency>
-
-      <dependency>
-        <groupId>javax.xml.bind</groupId>
-        <artifactId>jaxb-api</artifactId>
-        <version>${jaxb-api-version}</version>
-        <scope>provided</scope>
-        <exclusions>
-          <exclusion>
-            <groupId>javax.xml</groupId>
-            <artifactId>jsr173</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>javax.activation</groupId>
-            <artifactId>activation</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>com.sun.xml.bind</groupId>
-        <artifactId>jaxb-impl</artifactId>
-        <version>${jaxb-impl-version}</version>
-        <scope>provided</scope>
-        <exclusions>
-          <exclusion>
-            <groupId>javax.xml</groupId>
-            <artifactId>jsr173</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>javax.jws</groupId>
-            <artifactId>jsr181-api</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>javax.activation</groupId>
-            <artifactId>activation</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>com.sun.xml.bind</groupId>
-        <artifactId>jaxb-xjc</artifactId>
-        <version>${jaxb-xjc-version}</version>
-        <scope>provided</scope>
-        <exclusions>
-          <exclusion>
-            <groupId>javax.xml.bind</groupId>
-            <artifactId>jsr173_api</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-
-      <dependency>
-        <groupId>org.codehaus.woodstox</groupId>
-        <artifactId>wstx-asl</artifactId>
-        <version>${woodstox-version}</version>
-        <scope>provided</scope>
-      </dependency>
-
-      <dependency>
-        <groupId>wsdl4j</groupId>
-        <artifactId>wsdl4j</artifactId>
-        <version>${wsdl4j-version}</version>
-        <scope>provided</scope>
-      </dependency>
-      
-      <dependency>
-        <groupId>xalan</groupId>
-        <artifactId>xalan</artifactId>
-        <version>${xalan-version}</version>
-        <scope>provided</scope>
-      </dependency>
-
-      <dependency>
-        <groupId>xerces</groupId>
-        <artifactId>xercesImpl</artifactId>
-        <version>${xercesImpl-version}</version>
-        <scope>provided</scope>
-      </dependency>
-
-      <dependency>
-        <groupId>xml-apis</groupId>
-        <artifactId>xml-apis</artifactId>
-        <version>${xml-apis-version}</version>
-        <scope>provided</scope>
-      </dependency>
-      
-      <dependency>
-        <groupId>xerces</groupId>
-        <artifactId>xmlParserAPIs</artifactId>
-        <version>${xmlParserAPIs-version}</version>
-        <scope>provided</scope>
-      </dependency>
-
-      <dependency>
-        <groupId>junit</groupId>
-        <artifactId>junit</artifactId>
-        <version>${junit-version}</version>
-        <scope>test</scope>
-      </dependency>
-
-      <!-- 
-        We should work on moving these dependencies down into the component poms.. 
-        leaving commented to that components can cut and paste their dependencies 
-        more easily.
-      -->
-      <!--
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-jbi</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-core</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-services</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-audit</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-components</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-common</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-console</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-gbean</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-jms</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-jsr181</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-http</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-mail</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-osworkflow</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-sca</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-soap</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-soap2</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-shared</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-wsn2005</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-lwcontainer</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-bean</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-eip</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-script</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-file</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-ftp</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-xmpp</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-quartz</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-saxon</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-truezip</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-cxf-bc</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-cxf-se</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-camel</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix.samples</groupId>
-        <artifactId>servicemix-web</artifactId>
-        <version>${servicemix-version}</version>
-        <type>war</type>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix.samples</groupId>
-        <artifactId>wsdl-first</artifactId>
-        <version>${servicemix-version}</version>
-        <type>pom</type>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix.samples</groupId>
-        <artifactId>cxf-wsdl-first</artifactId>
-        <version>${servicemix-version}</version>
-        <type>pom</type>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix.samples</groupId>
-        <artifactId>loan-broker</artifactId>
-        <version>${servicemix-version}</version>
-        <type>pom</type>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix.samples</groupId>
-        <artifactId>bridge</artifactId>
-        <version>${servicemix-version}</version>
-        <type>pom</type>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix.samples</groupId>
-        <artifactId>basic</artifactId>
-        <version>${servicemix-version}</version>
-        <type>pom</type>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-beanflow</artifactId>
-        <version>${servicemix-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix</groupId>
-        <artifactId>servicemix-web-console</artifactId>
-        <version>${servicemix-version}</version>
-        <type>war</type>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.servicemix.dependencies</groupId>
-        <artifactId>jsr-223</artifactId>
-        <version>1.0-pr</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.ws</groupId>
-        <artifactId>wsif</artifactId>
-        <version>2.0.1_IB3</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.ws</groupId>
-        <artifactId>wsif-j2c</artifactId>
-        <version>2.0.1_IB3</version>
-      </dependency>
-      <dependency>
-        <groupId>javax.xml.ws</groupId>
-        <artifactId>jaxws-api</artifactId>
-        <version>2.0</version>
-      </dependency>
-      <dependency>
-        <groupId>xfire</groupId>
-        <artifactId>xfire-jsr181-api</artifactId>
-        <version>${xfire-jsr181-api-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.activemq</groupId>
-        <artifactId>activeio-core</artifactId>
-        <version>${activeio-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.activemq</groupId>
-        <artifactId>activemq-core</artifactId>
-        <version>${activemq-version}</version>
-        <exclusions>
-          <exclusion>
-            <groupId>org.springframework</groupId>
-            <artifactId>spring</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.activemq</groupId>
-        <artifactId>activemq-ra</artifactId>
-        <version>${activemq-version}</version>
-        <exclusions>
-          <exclusion>
-            <groupId>org.springframework</groupId>
-            <artifactId>spring</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>activemq</groupId>
-            <artifactId>jmdns</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.activemq</groupId>
-        <artifactId>activemq-web</artifactId>
-        <version>${activemq-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>jivesoftware</groupId>
-        <artifactId>smack</artifactId>
-        <version>2.2.1</version>
-      </dependency>
-      <dependency>
-        <groupId>jivesoftware</groupId>
-        <artifactId>smackx</artifactId>
-        <version>2.2.1</version>
-      </dependency>
-      <dependency>
-        <groupId>activesoap</groupId>
-        <artifactId>activesoap</artifactId>
-        <version>1.0-20050615.083700</version>
-      </dependency>
-      <dependency>
-        <groupId>annogen</groupId>
-        <artifactId>annogen</artifactId>
-        <version>0.1.0</version>
-      </dependency>
-      <dependency>
-        <groupId>ant</groupId>
-        <artifactId>ant</artifactId>
-        <version>1.6.5</version>
-      </dependency>
-      <dependency>
-        <groupId>antlr</groupId>
-        <artifactId>antlr</artifactId>
-        <version>2.7.5</version>
-      </dependency>
-      <dependency>
-        <groupId>axis</groupId>
-        <artifactId>axis</artifactId>
-        <version>1.3</version>
-      </dependency>
-      <dependency>
-        <groupId>axis</groupId>
-        <artifactId>axis-jaxrpc</artifactId>
-        <version>1.3</version>
-      </dependency>
-      <dependency>
-        <groupId>axis</groupId>
-        <artifactId>axis-saaj</artifactId>
-        <version>1.3</version>
-      </dependency>
-      <dependency>
-        <groupId>backport-util-concurrent</groupId>
-        <artifactId>backport-util-concurrent</artifactId>
-        <version>${backport-util-concurrent-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>castor</groupId>
-        <artifactId>castor</artifactId>
-        <version>0.9.5.3</version>
-      </dependency>
-      <dependency>
-        <groupId>cglib</groupId>
-        <artifactId>cglib</artifactId>
-        <version>2.1_3</version>
-      </dependency>
-      <dependency>
-        <groupId>cglib</groupId>
-        <artifactId>cglib-full</artifactId>
-        <version>2.0</version>
-      </dependency>
-      <dependency>
-        <groupId>cglib</groupId>
-        <artifactId>cglib-nodep</artifactId>
-        <version>2.1_3</version>
-      </dependency>
-      <dependency>
-        <groupId>classworlds</groupId>
-        <artifactId>classworlds</artifactId>
-        <version>1.0.1</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-attributes</groupId>
-        <artifactId>commons-attributes-api</artifactId>
-        <version>2.1</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-attributes</groupId>
-        <artifactId>commons-attributes-plugin</artifactId>
-        <version>2.1</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-beanutils</groupId>
-        <artifactId>commons-beanutils-core</artifactId>
-        <version>${commons-beanutils-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-beanutils</groupId>
-        <artifactId>commons-beanutils</artifactId>
-        <version>1.7.0</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-codec</groupId>
-        <artifactId>commons-codec</artifactId>
-        <version>1.3</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-collections</groupId>
-        <artifactId>commons-collections</artifactId>
-        <version>3.1</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-dbcp</groupId>
-        <artifactId>commons-dbcp</artifactId>
-        <version>1.2.1</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-discovery</groupId>
-        <artifactId>commons-discovery</artifactId>
-        <version>0.2</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-el</groupId>
-        <artifactId>commons-el</artifactId>
-        <version>1.0</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-httpclient</groupId>
-        <artifactId>commons-httpclient</artifactId>
-        <version>3.0</version>
-        <exclusions>
-          <exclusion>
-            <groupId>junit</groupId>
-            <artifactId>junit</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>commons-io</groupId>
-        <artifactId>commons-io</artifactId>
-        <version>1.3.1</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-lang</groupId>
-        <artifactId>commons-lang</artifactId>
-        <version>2.1</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-net</groupId>
-        <artifactId>commons-net</artifactId>
-        <version>1.4.1</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-pool</groupId>
-        <artifactId>commons-pool</artifactId>
-        <version>1.2</version>
-        <exclusions>
-          <exclusion>
-            <groupId>xerces</groupId>
-            <artifactId>xerces</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>commons-primitives</groupId>
-        <artifactId>commons-primitives</artifactId>
-        <version>1.0</version>
-      </dependency>
-      <dependency>
-        <groupId>commons-vfs</groupId>
-        <artifactId>commons-vfs</artifactId>
-        <version>20050307052300</version>
-      </dependency>
-      <dependency>
-        <groupId>concurrent</groupId>
-        <artifactId>concurrent</artifactId>
-        <version>1.3.4</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.derby</groupId>
-        <artifactId>derby</artifactId>
-        <version>${derby-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>drools</groupId>
-        <artifactId>drools-all-jdk1.4</artifactId>
-        <version>2.1</version>
-      </dependency>
-      <dependency>
-        <groupId>drools</groupId>
-        <artifactId>drools-core</artifactId>
-        <version>2.1</version>
-      </dependency>
-      <dependency>
-        <groupId>easymock</groupId>
-        <artifactId>easymock</artifactId>
-        <version>1.2_Java1.3</version>
-      </dependency>
-      <dependency>
-        <groupId>emberio</groupId>
-        <artifactId>emberio</artifactId>
-        <version>0.3-alpha</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-activation</artifactId>
-        <version>${geronimo-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-common</artifactId>
-        <version>${geronimo-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-connector</artifactId>
-        <version>${geronimo-version}</version>
-        <exclusions>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-kernel</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-system</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-security</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-core</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-j2ee</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-common</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-management</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-naming</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-deployment</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-core</artifactId>
-        <version>${geronimo-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-deployment</artifactId>
-        <version>${geronimo-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-j2ee</artifactId>
-        <version>${geronimo-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-kernel</artifactId>
-        <version>${geronimo-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-network</artifactId>
-        <version>${geronimo-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-remoting</artifactId>
-        <version>${geronimo-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-security</artifactId>
-        <version>${geronimo-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-system</artifactId>
-        <version>${geronimo-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.modules</groupId>
-        <artifactId>geronimo-transaction</artifactId>
-        <version>${geronimo-version}</version>
-        <exclusions>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-j2ee</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.apache.geronimo.modules</groupId>
-            <artifactId>geronimo-core</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-activation_1.0.2_spec</artifactId>
-        <version>1.2</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-ejb_2.1_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-j2ee-connector_1.5_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-jaxrpc_1.1_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-j2ee-management_1.0_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-jms_1.1_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-jsp_2.0_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-saaj_1.1_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-jta_1.0.1B_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-servlet_2.4_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-qname_1.1_spec</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.geronimo.specs</groupId>
-        <artifactId>geronimo-javamail_1.3.1_spec</artifactId>
-        <version>1.2</version>
-      </dependency>
-      <dependency>
-        <groupId>groovy</groupId>
-        <artifactId>groovy-all-1.0-jsr</artifactId>
-        <version>04</version>
-      </dependency>
-      <dependency>
-        <groupId>hsqldb</groupId>
-        <artifactId>hsqldb</artifactId>
-        <version>1.7.3.3</version>
-      </dependency>
-      <dependency>
-        <groupId>janino</groupId>
-        <artifactId>janino</artifactId>
-        <version>2.3.2</version>
-      </dependency>
-      <dependency>
-        <groupId>jaxen</groupId>
-        <artifactId>jaxen</artifactId>
-        <version>1.1-beta-9</version>
-        <exclusions>
-          <exclusion>
-            <groupId>jaxme</groupId>
-            <artifactId>jaxme-api</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>dom4j</groupId>
-            <artifactId>dom4j</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>xom</groupId>
-            <artifactId>xom</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>jdom</groupId>
-            <artifactId>jdom</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>xerces</groupId>
-            <artifactId>xmlParserAPIs</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>dom4j</groupId>
-        <artifactId>dom4j</artifactId>
-        <version>1.6.1</version>
-        <exclusions>
-          <exclusion>
-            <groupId>jaxme</groupId>
-            <artifactId>jaxme-api</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>jdom</groupId>
-        <artifactId>jdom</artifactId>
-        <version>1.0</version>
-      </dependency>
-      <dependency>
-        <groupId>org.jencks</groupId>
-        <artifactId>jencks</artifactId>
-        <version>${jencks-version}</version>
-        <exclusions>
-          <exclusion>
-            <groupId>org.springframework</groupId>
-            <artifactId>spring</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>jencks</groupId>
-            <artifactId>xapool-without-pool</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>org.mortbay.jetty</groupId>
-        <artifactId>jetty</artifactId>
-        <version>${jetty-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.mortbay.jetty</groupId>
-        <artifactId>jetty-xbean</artifactId>
-        <version>${jetty-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.mortbay.jetty</groupId>
-        <artifactId>jetty-util</artifactId>
-        <version>${jetty-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.mortbay.jetty</groupId>
-        <artifactId>jetty-management</artifactId>
-        <version>${jetty-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.mortbay.jetty</groupId>
-        <artifactId>servlet-api-2.5</artifactId>
-        <version>${jetty-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>javax.servlet</groupId>
-        <artifactId>jstl</artifactId>
-        <version>1.1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.logicblaze.lingo</groupId>
-        <artifactId>lingo</artifactId>
-        <version>1.3</version>
-        <exclusions>
-          <exclusion>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-transaction</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-connector</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>concurrent</groupId>
-            <artifactId>concurrent</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.springframework</groupId>
-            <artifactId>spring</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>cglib</groupId>
-            <artifactId>cglib-full</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>aopalliance</groupId>
-            <artifactId>aopalliance</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>geronimo-spec</groupId>
-            <artifactId>geronimo-spec-jms</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>geronimo-spec</groupId>
-            <artifactId>geronimo-spec-jta</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>geronimo-spec</groupId>
-            <artifactId>geronimo-spec-j2ee-management</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>geronimo-spec</groupId>
-            <artifactId>geronimo-spec-j2ee-connector</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>incubator-activemq</groupId>
-            <artifactId>activemq-core</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>incubator-activemq</groupId>
-            <artifactId>activeio-core</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>incubator-activemq</groupId>
-            <artifactId>activemq-ra</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>jencks</groupId>
-            <artifactId>jencks-all</artifactId>
-          </exclusion>
+    <dependencies>
+      
+      <!-- Keep the most common dependencies here to help avoid conflicts across components -->
+      <!-- But if we put too much stuff here we will have to release this pom often, since we would need
+           a release every time a dependency changes -->
+      <dependency>
+        <groupId>commons-logging</groupId>
+        <artifactId>commons-logging</artifactId>
+        <version>${commons-logging-version}</version>
+        <optional>true</optional>
+        <scope>provided</scope>
+        <exclusions>
           <exclusion>
-            <groupId>xmlpull</groupId>
-            <artifactId>xmlpull</artifactId>
+            <groupId>avalon-framework</groupId>
+            <artifactId>avalon-framework</artifactId>
           </exclusion>
           <exclusion>
-            <groupId>hsqldb</groupId>
-            <artifactId>hsqldb</artifactId>
+            <groupId>logkit</groupId>
+            <artifactId>logkit</artifactId>
           </exclusion>
           <exclusion>
-            <groupId>backport175</groupId>
-            <artifactId>backport175</artifactId>
+            <groupId>javax.servlet</groupId>
+            <artifactId>servlet-api</artifactId>
           </exclusion>
         </exclusions>
       </dependency>
+      
       <dependency>
-        <groupId>log4j</groupId>
-        <artifactId>log4j</artifactId>
-        <version>1.2.13</version>
-      </dependency>
-      <dependency>
-        <groupId>mx4j</groupId>
-        <artifactId>mx4j</artifactId>
-        <version>3.0.1</version>
-      </dependency>
-      <dependency>
-        <groupId>mx4j</groupId>
-        <artifactId>mx4j-remote</artifactId>
-        <version>3.0.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.pluto</groupId>
-        <artifactId>pluto</artifactId>
-        <version>1.0.1</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.pluto</groupId>
-        <artifactId>pluto-descriptors</artifactId>
-        <version>1.0.1</version>
+        <groupId>org.springframework</groupId>
+        <artifactId>spring</artifactId>
+        <version>${spring-version}</version>
+        <scope>provided</scope>
       </dependency>
       <dependency>
-        <groupId>org.apache.pluto</groupId>
-        <artifactId>pluto-portal</artifactId>
-        <version>1.0.1</version>
+        <groupId>org.springframework</groupId>
+        <artifactId>spring-support</artifactId>
+        <version>${spring-version}</version>
+        <scope>provided</scope>
       </dependency>
       <dependency>
-        <groupId>portlet-api</groupId>
-        <artifactId>portlet-api</artifactId>
-        <version>1.0</version>
+        <groupId>org.springframework</groupId>
+        <artifactId>spring-aop</artifactId>
+        <version>${spring-version}</version>
+        <scope>provided</scope>
       </dependency>
       <dependency>
-        <groupId>quartz</groupId>
-        <artifactId>quartz</artifactId>
-        <version>1.5.2</version>
+        <groupId>org.springframework</groupId>
+        <artifactId>spring-jmx</artifactId>
+        <version>${spring-version}</version>
+        <scope>provided</scope>
       </dependency>
       <dependency>
-        <groupId>rome</groupId>
-        <artifactId>rome</artifactId>
-        <version>0.5</version>
+        <groupId>org.springframework</groupId>
+        <artifactId>spring-context</artifactId>
+        <version>${spring-version}</version>
+        <scope>provided</scope>
       </dependency>
       <dependency>
         <groupId>org.springframework</groupId>
-        <artifactId>spring</artifactId>
+        <artifactId>spring-beans</artifactId>
         <version>${spring-version}</version>
+        <scope>provided</scope>
       </dependency>
       <dependency>
-        <groupId>taglibs</groupId>
-        <artifactId>standard</artifactId>
-        <version>1.1.2</version>
+        <groupId>org.springframework</groupId>
+        <artifactId>spring-core</artifactId>
+        <version>${spring-version}</version>
+        <scope>provided</scope>
       </dependency>
       <dependency>
-        <groupId>org.apache.xbean</groupId>
-        <artifactId>xbean-spring</artifactId>
-        <version>${xbean-version}</version>
+        <groupId>org.springframework</groupId>
+        <artifactId>spring-remoting</artifactId>
+        <version>${spring-version}</version>
+        <scope>provided</scope>
         <exclusions>
           <exclusion>
             <groupId>org.springframework</groupId>
-            <artifactId>spring</artifactId>
-          </exclusion>
-        </exclusions>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.xbean</groupId>
-        <artifactId>xbean-classloader</artifactId>
-        <version>${xbean-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.codehaus.xfire</groupId>
-        <artifactId>xfire-all</artifactId>
-        <version>${xfire-version}</version>
-        <exclusions>
-          <exclusion>
-            <groupId>javax.mail</groupId>
-            <artifactId>mail</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>jetty</groupId>
-            <artifactId>org.mortbay.jetty</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>xfire</groupId>
-            <artifactId>jaxb-api</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>jaxb</groupId>
-            <artifactId>jaxb-api</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>xfire</groupId>
-            <artifactId>jaxb-impl</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>jaxb</groupId>
-            <artifactId>jaxb-impl</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>xfire</groupId>
-            <artifactId>sun-saaj-impl</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>xfire</groupId>
-            <artifactId>sun-saaj-api</artifactId>
+            <artifactId>spring-web</artifactId>
           </exclusion>
           <exclusion>
-            <groupId>xfire</groupId>
-            <artifactId>sun-jaxws-api</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>xfire</groupId>
-            <artifactId>jaxb-xjc</artifactId>
+            <groupId>org.springframework</groupId>
+            <artifactId>spring-aop</artifactId>
           </exclusion>
           <exclusion>
-            <groupId>javax.xml</groupId>
-            <artifactId>jsr173</artifactId>
+            <groupId>aopalliance</groupId>
+            <artifactId>aopalliance</artifactId>
           </exclusion>
         </exclusions>
       </dependency>
+
+      <dependency>
+        <groupId>stax</groupId>
+        <artifactId>stax-api</artifactId>
+        <version>${stax-api-version}</version>
+        <scope>provided</scope>
+      </dependency>
+
       <dependency>
-        <groupId>org.codehaus.xfire</groupId>
-        <artifactId>xfire-jaxb2</artifactId>
-        <version>${xfire-version}</version>
+        <groupId>javax.xml.bind</groupId>
+        <artifactId>jaxb-api</artifactId>
+        <version>${jaxb-api-version}</version>
+        <scope>provided</scope>
         <exclusions>
           <exclusion>
-            <groupId>httpunit</groupId>
-            <artifactId>httpunit</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>jetty</groupId>
-            <artifactId>org.mortbay.jetty</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>commons-httpclient</groupId>
-            <artifactId>commons-httpclient</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>javax.mail</groupId>
-            <artifactId>mail</artifactId>
+            <groupId>javax.xml</groupId>
+            <artifactId>jsr173</artifactId>
           </exclusion>
           <exclusion>
             <groupId>javax.activation</groupId>
             <artifactId>activation</artifactId>
           </exclusion>
-          <exclusion>
-            <groupId>ant</groupId>
-            <artifactId>ant</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>commons-beanutils</groupId>
-            <artifactId>commons-beanutils</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>qdox</groupId>
-            <artifactId>qdox</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>com.sun.xml.bind</groupId>
-            <artifactId>jaxb-xjc</artifactId>
-          </exclusion>
         </exclusions>
       </dependency>
       <dependency>
-        <groupId>org.codehaus.xfire</groupId>
-        <artifactId>xfire-xmlbeans</artifactId>
-        <version>${xfire-version}</version>
+        <groupId>com.sun.xml.bind</groupId>
+        <artifactId>jaxb-impl</artifactId>
+        <version>${jaxb-impl-version}</version>
+        <scope>provided</scope>
         <exclusions>
           <exclusion>
-            <groupId>httpunit</groupId>
-            <artifactId>httpunit</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>jetty</groupId>
-            <artifactId>org.mortbay.jetty</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>commons-httpclient</groupId>
-            <artifactId>commons-httpclient</artifactId>
+            <groupId>javax.xml</groupId>
+            <artifactId>jsr173</artifactId>
           </exclusion>
           <exclusion>
-            <groupId>javax.mail</groupId>
-            <artifactId>mail</artifactId>
+            <groupId>javax.jws</groupId>
+            <artifactId>jsr181-api</artifactId>
           </exclusion>
           <exclusion>
             <groupId>javax.activation</groupId>
             <artifactId>activation</artifactId>
           </exclusion>
-          <exclusion>
-            <groupId>ant</groupId>
-            <artifactId>ant</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>commons-beanutils</groupId>
-            <artifactId>commons-beanutils</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>qdox</groupId>
-            <artifactId>qdox</artifactId>
-          </exclusion>
         </exclusions>
       </dependency>
       <dependency>
-        <groupId>org.codehaus.xfire</groupId>
-        <artifactId>xfire-castor</artifactId>
-        <version>${xfire-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>org.codehaus.xfire</groupId>
-        <artifactId>xfire-jibx</artifactId>
-        <version>${xfire-version}</version>
-      </dependency>
-      <dependency>
-        <groupId>xmlbeans</groupId>
-        <artifactId>xbean</artifactId>
-        <version>2.1.0</version>
-      </dependency>
-      <dependency>
-        <groupId>xmlbeans</groupId>
-        <artifactId>xbean_xpath</artifactId>
-        <version>2.1.0</version>
-      </dependency>
-      <dependency>
-        <groupId>xmlbeans</groupId>
-        <artifactId>xmlpublic</artifactId>
-        <version>2.1.0</version>
-      </dependency>
-      <dependency>
-        <groupId>xstream</groupId>
-        <artifactId>xstream</artifactId>
-        <version>1.1.2</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.ws.commons.schema</groupId>
-        <artifactId>XmlSchema</artifactId>
-        <version>1.3.2</version>
-      </dependency>
-      <dependency>
-        <groupId>lucene</groupId>
-        <artifactId>lucene</artifactId>
-        <version>1.4.3</version>
-      </dependency>
-      <dependency>
-        <groupId>net.java.dev.saaj</groupId>
-        <artifactId>saaj-impl</artifactId>
-        <version>ea3</version>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.ode</groupId>
-        <artifactId>bpe</artifactId>
-        <version>1.0-20070108</version>
-      </dependency>
-      <dependency>
-        <groupId>org.slf4j</groupId>
-        <artifactId>slf4j-jcl</artifactId>
-        <version>1.0.1</version>
-      </dependency>
-      <dependency>
-        <groupId>tranql</groupId>
-        <artifactId>tranql-connector</artifactId>
-        <version>1.1</version>
+        <groupId>com.sun.xml.bind</groupId>
+        <artifactId>jaxb-xjc</artifactId>
+        <version>${jaxb-xjc-version}</version>
+        <scope>provided</scope>
         <exclusions>
           <exclusion>
-            <groupId>axion</groupId>
-            <artifactId>axion</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>geronimo-spec</groupId>
-            <artifactId>geronimo-spec-jta</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>geronimo-spec</groupId>
-            <artifactId>geronimo-spec-j2ee-connector</artifactId>
+            <groupId>javax.xml.bind</groupId>
+            <artifactId>jsr173_api</artifactId>
           </exclusion>
         </exclusions>
       </dependency>
+
       <dependency>
-        <groupId>org.apache.ws.security</groupId>
-        <artifactId>wss4j</artifactId>
-        <version>1.5.2</version>
-      </dependency>
-      <dependency>
-        <groupId>bouncycastle</groupId>
-        <artifactId>bcprov-jdk14</artifactId>
-        <version>136</version>
-      </dependency>
-      <dependency>
-        <groupId>org.opensaml</groupId>
-        <artifactId>opensaml</artifactId>
-        <version>1.1</version>
-      </dependency>
-      <dependency>
-        <groupId>xml-security</groupId>
-        <artifactId>xmlsec</artifactId>
-        <version>1.3.0</version>
-      </dependency>
-      <dependency>
-        <groupId>org.objectweb.howl</groupId>
-        <artifactId>howl</artifactId>
-        <version>1.0.1-1</version>
-      </dependency>
-      <dependency>
-        <groupId>msv</groupId>
-        <artifactId>msv</artifactId>
-        <version>${msv-version}</version>
+        <groupId>org.codehaus.woodstox</groupId>
+        <artifactId>wstx-asl</artifactId>
+        <version>${woodstox-version}</version>
+        <scope>provided</scope>
       </dependency>
+
       <dependency>
-        <groupId>msv</groupId>
-        <artifactId>relaxngDatatype</artifactId>
-        <version>${msv-version}</version>
+        <groupId>wsdl4j</groupId>
+        <artifactId>wsdl4j</artifactId>
+        <version>${wsdl4j-version}</version>
+        <scope>provided</scope>
       </dependency>
+      
       <dependency>
-        <groupId>msv</groupId>
-        <artifactId>xsdlib</artifactId>
-        <version>${msv-version}</version>
+        <groupId>xalan</groupId>
+        <artifactId>xalan</artifactId>
+        <version>${xalan-version}</version>
+        <scope>provided</scope>
       </dependency>
+
       <dependency>
-        <groupId>oro</groupId>
-        <artifactId>oro</artifactId>
-        <version>${oro-version}</version>
+        <groupId>xerces</groupId>
+        <artifactId>xercesImpl</artifactId>
+        <version>${xercesImpl-version}</version>
+        <scope>provided</scope>
       </dependency>
+
       <dependency>
-        <groupId>opensymphony</groupId>
-        <artifactId>sitemesh</artifactId>
-        <version>${sitemesh-version}</version>
+        <groupId>xml-apis</groupId>
+        <artifactId>xml-apis</artifactId>
+        <version>${xml-apis-version}</version>
+        <scope>provided</scope>
       </dependency>
+      
       <dependency>
-        <groupId>commons-fileupload</groupId>
-        <artifactId>commons-fileupload</artifactId>
-        <version>${commons-fileupload-version}</version>
+        <groupId>xerces</groupId>
+        <artifactId>xmlParserAPIs</artifactId>
+        <version>${xmlParserAPIs-version}</version>
+        <scope>provided</scope>
       </dependency>
+
       <dependency>
-        <groupId>org.apache.woden</groupId>
-        <artifactId>woden</artifactId>
-        <version>${woden-version}</version>
-        <exclusions>
-          <exclusion>
-            <groupId>org.apache.ws.commons.axiom</groupId>
-            <artifactId>axiom-impl</artifactId>
-          </exclusion>
-          <exclusion>
-            <groupId>org.apache.ws.commons</groupId>
-            <artifactId>XmlSchema</artifactId>
-          </exclusion>
-        </exclusions>
+        <groupId>junit</groupId>
+        <artifactId>junit</artifactId>
+        <version>${junit-version}</version>
+        <scope>test</scope>
       </dependency>
-    -->
+
     </dependencies>
   </dependencyManagement>
 
@@ -2023,14 +843,11 @@
     </profile>
   </profiles>
   
-<!-- 
-  Most components should build fine just using the central maven repo.. adding all the possible 
-  repo location in this parent pom just slows down the dowloads for other components since 
-  it's going to check all the repos listed.  Keep this section commented out, and only enable
-  if a dependency does not download from the central repo. Use it to fine the repo that has the 
-  dependency and add that repo to just that component so only that component pays the price of checking
-  multiple repos. 
--->
+  <!-- 
+    Most components should build fine just using the central maven repo.. adding all the possible 
+    repo location in this parent pom just slows down the dowloads for other components since 
+    it's going to check all the repos listed.  Add additional repos only to component poms.
+  -->
   <repositories>
       <repository>
           <id>apache-snapshots</id>
@@ -2043,40 +860,6 @@
               <enabled>true</enabled>
           </snapshots>
       </repository>
-<!--      
-      <repository>
-          <id>servicemix-m2-repo</id>
-          <name>Servicemix Maven2 Repository</name>
-          <url>http://svn.apache.org/repos/asf/servicemix/m2-repo/</url>
-      </repository>
-      <repository>
-          <id>apache-incubating</id>
-          <name>Apache Incubating Repository</name>
-          <url>http://people.apache.org/repo/m2-incubating-repository</url>
-          <releases>
-              <enabled>true</enabled>
-          </releases>
-          <snapshots>
-              <enabled>false</enabled>
-          </snapshots>
-      </repository>
-      <repository>
-          <id>codehaus</id>
-          <name>Codehaus repository</name>
-          <url>http://repository.codehaus.org</url>
-          <releases>
-              <enabled>true</enabled>
-          </releases>
-          <snapshots>
-              <enabled>true</enabled>
-          </snapshots>
-      </repository>
-      <repository>
-          <id>java.net</id>
-          <url>http://download.java.net/maven/1</url>
-          <layout>legacy</layout>
-      </repository>
--->        
   </repositories>
   <pluginRepositories>
       <pluginRepository>
@@ -2090,35 +873,6 @@
               <enabled>true</enabled>
           </snapshots>
       </pluginRepository>
-<!--      
-      <pluginRepository>
-          <id>apache-releases</id>
-          <name>Apache Releases repository</name>
-          <url>http://people.apache.org/repo/m2-ibiblio-rsync-repository</url>
-          <releases>
-              <enabled>true</enabled>
-          </releases>
-          <snapshots>
-              <enabled>false</enabled>
-          </snapshots>
-      </pluginRepository>
-      <pluginRepository>
-          <id>servicemix-m2-repo</id>
-          <name>Servicemix Maven2 Repository</name>
-          <url>http://svn.apache.org/repos/asf/servicemix/m2-repo/</url>
-      </pluginRepository>
-      <pluginRepository>
-          <id>apache-incubating</id>
-          <name>Apache Incubating Repository</name>
-          <url>http://people.apache.org/repo/m2-incubating-repository</url>
-          <releases>
-              <enabled>true</enabled>
-          </releases>
-          <snapshots>
-              <enabled>false</enabled>
-          </snapshots>
-      </pluginRepository>
--->        
   </pluginRepositories>  
   
   <!--



Mime
View raw message