shiro-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kao...@apache.org
Subject svn commit: r1689797 - /shiro/branches/1.2.x/pom.xml
Date Wed, 08 Jul 2015 06:23:04 GMT
Author: kaosko
Date: Wed Jul  8 06:23:03 2015
New Revision: 1689797

URL: http://svn.apache.org/r1689797
Log:
configure toolchains plugin to require jdk 1.6 while being able to deploy with a newer jdk
because of https://issues.apache.org/jira/browse/BUILDS-85. Bump jdk version requirement from
1.5 to 1.6

Modified:
    shiro/branches/1.2.x/pom.xml

Modified: shiro/branches/1.2.x/pom.xml
URL: http://svn.apache.org/viewvc/shiro/branches/1.2.x/pom.xml?rev=1689797&r1=1689796&r2=1689797&view=diff
==============================================================================
--- shiro/branches/1.2.x/pom.xml (original)
+++ shiro/branches/1.2.x/pom.xml Wed Jul  8 06:23:03 2015
@@ -1,4 +1,4 @@
-ml version="1.0" encoding="UTF-8"?>
+<?xml version="1.0" encoding="UTF8"?>
 <!--
   ~ Licensed to the Apache Software Foundation (ASF) under one
   ~ or more contributor license agreements.  See the NOTICE file
@@ -81,7 +81,7 @@
              modules' OSGi metadata: -->
         <ehcache.version>2.5.0</ehcache.version>
         <hsqldb.version>1.8.0.7</hsqldb.version>
-        <jdk.version>1.5</jdk.version>
+        <jdk.version>1.6</jdk.version>
         <jetty.version>6.1.26</jetty.version>
         <!-- Don't change this version without also changing the shiro-quartz and shiro-features
              modules' OSGi metadata: -->
@@ -369,6 +369,29 @@
                     <printSummary>true</printSummary>
                 </configuration>
             </plugin>
+            <!-- repository.apache.org doesn't accept connections from jdk 1.6 (https://issues.apache.org/jira/browse/BUILDS-85)
so use toolchains
+            to require jdk 1.6 for compiling but deploy using a newer jdk
+            -->
+            <plugin>
+              <groupId>org.apache.maven.plugins</groupId>
+              <artifactId>maven-toolchains-plugin</artifactId>
+              <version>1.1</version>
+              <configuration>
+                <toolchains>
+                  <jdk>
+                    <version>1.6</version>
+                    <vendor>sun</vendor>
+                  </jdk>
+                </toolchains>               
+              </configuration>
+              <executions>
+                <execution>
+                  <goals>
+                    <goal>toolchain</goal>
+                  </goals>
+                </execution>
+              </executions>
+            </plugin>
             <!-- Allow Groovy tests to run: -->
             <plugin>
                 <groupId>org.codehaus.gmaven</groupId>



Mime
View raw message