spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jimfcarroll <jimfcarr...@gmail.com>
Subject Problem with version compatibility
Date Wed, 24 Jun 2015 18:21:34 GMT

Hello all,

I have a strange problem. I have a mesos spark cluster with Spark
1.4.0/Hadoop 2.4.0 installed and a client application use maven to include
the same versions.

However, I'm getting a serialUIDVersion problem on:

ERROR Remoting -
org.apache.spark.storage.BlockManagerMessages$RegisterBlockManager; local
class incompatible: stream classdesc serialVersionUID = 3833981923223309323,
local class serialVersionUID = -1833407448843930116

When I look in the jar file of the spark dependency in my maven repo I see:

spark-core_2.10-1.4.0.jar contains the line:
2917  10-Jun-2015  12:20:48 
org/apache/spark/storage/BlockManagerMessages$RegisterBlockManager$.class

However, on my mesos cluster the jar looks like this:

spark-assembly-1.4.0-hadoop2.4.0.jar contains the line:
3786   2-Jun-2015  18:23:00 
org/apache/spark/storage/BlockManagerMessages$RegisterBlockManager.class

Notice the classes aren't the same (different sizes), but I'm getting them
both from hosted repositories. One is from maven central and the other is
from the download page which points to here:
http://d3kbcqa49mib13.cloudfront.net/spark-1.4.0-bin-hadoop2.4.tgz

Thanks
Jim




--
View this message in context: http://apache-spark-developers-list.1001551.n3.nabble.com/Problem-with-version-compatibility-tp12861.html
Sent from the Apache Spark Developers List mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@spark.apache.org
For additional commands, e-mail: dev-help@spark.apache.org


Mime
View raw message