spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <so...@cloudera.com>
Subject Re: PMML version in MLLib
Date Wed, 04 Nov 2015 11:52:28 GMT
I'm pretty sure that attribute is required. I am not sure what PMML
version the code has been written for but would assume 4.2.1. Feel
free to open a PR to add this version to all the output.

On Wed, Nov 4, 2015 at 11:42 AM, Fazlan Nazeem <fazlann@wso2.com> wrote:
> [adding dev]
>
> On Wed, Nov 4, 2015 at 2:27 PM, Fazlan Nazeem <fazlann@wso2.com> wrote:
>>
>> I just went through all specifications, and they expect the version
>> attribute. This should be addressed very soon because if we cannot use the
>> PMML model without the version attribute, there is no use of generating one
>> without it.
>>
>> On Wed, Nov 4, 2015 at 2:17 PM, Stefano Baghino
>> <stefano.baghino@radicalbit.io> wrote:
>>>
>>> I used KNIME, which internally uses the org.dmg.pmml library.
>>>
>>> On Wed, Nov 4, 2015 at 9:45 AM, Fazlan Nazeem <fazlann@wso2.com> wrote:
>>>>
>>>> Hi Stefano,
>>>>
>>>> Although the intention for my question wasn't as you expected, what you
>>>> say makes sense. The standard[1] for PMML 4.1 specifies that "For PMML 4.1
>>>> the attribute version must have the value 4.1". I'm not sure whether that
>>>> means that other PMML versions do not need that attribute to be set
>>>> explicitly. I hope someone would answer this.
>>>>
>>>> What was the tool you used to load the PMML?
>>>>
>>>> [1] http://dmg.org/pmml/v4-1/GeneralStructure.html
>>>>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@spark.apache.org
For additional commands, e-mail: dev-help@spark.apache.org


Mime
View raw message