spark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Can't compile 2.0-preview with scala 2.10
Date Mon, 06 Jun 2016 17:41:37 GMT
See the following from
https://amplab.cs.berkeley.edu/jenkins/view/Spark%20QA%20Compile/job/SPARK-master-COMPILE-sbt-SCALA-2.10/1642/consoleFull
:

+ SBT_FLAGS+=('-Dscala-2.10')
+ ./dev/change-scala-version.sh 2.10


FYI


On Mon, Jun 6, 2016 at 10:35 AM, Franklyn D'souza <
franklyn.dsouza@shopify.com> wrote:

> Hi,
>
> I've checked out the 2.0-preview and attempted to build it
> with ./dev/make-distribution.sh -Pscala-2.10
>
> However i keep getting
>
> [INFO] --- maven-enforcer-plugin:1.4.1:enforce (enforce-versions) @
> spark-parent_2.11 ---
> [WARNING] Rule 0: org.apache.maven.plugins.enforcer.BannedDependencies
> failed with message:
> Found Banned Dependency: org.scala-lang.modules:scala-xml_2.11:jar:1.0.2
> Found Banned Dependency: org.scalatest:scalatest_2.11:jar:2.2.6
>
> Is scala 2.10 not being supported going forward ?. If so the profile
> should probably be removed from the master pom.xml
>
>
> Thanks,
>
> Franklyn
>
>
>

Mime
View raw message