spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Wendell (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-4014) TaskContext.attemptId returns taskId
Date Tue, 21 Oct 2014 07:02:33 GMT

    [ https://issues.apache.org/jira/browse/SPARK-4014?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14178053#comment-14178053
] 

Patrick Wendell commented on SPARK-4014:
----------------------------------------

[~joshrosen] what do you think about renaming this field (see associated discussion on dev
list). I agree that it's confusingly named at present.

> TaskContext.attemptId returns taskId
> ------------------------------------
>
>                 Key: SPARK-4014
>                 URL: https://issues.apache.org/jira/browse/SPARK-4014
>             Project: Spark
>          Issue Type: Bug
>          Components: Spark Core
>            Reporter: Yin Huai
>            Priority: Minor
>
> In TaskRunner, we assign the taskId of a task to the attempId of the corresponding TaskContext.
Should we rename attemptId to taskId to avoid confusion?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message