spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xiangrui Meng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-4022) Replace colt dependency (LGPL) with commons-math
Date Tue, 21 Oct 2014 01:26:34 GMT

    [ https://issues.apache.org/jira/browse/SPARK-4022?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14177784#comment-14177784
] 

Xiangrui Meng commented on SPARK-4022:
--------------------------------------

Colt is really old. Even the download link (http://acs.lbl.gov/software/colt/colt-download)
is broken. It is good if we switch to an alternative that is active and has no license issues.

> Replace colt dependency (LGPL) with commons-math
> ------------------------------------------------
>
>                 Key: SPARK-4022
>                 URL: https://issues.apache.org/jira/browse/SPARK-4022
>             Project: Spark
>          Issue Type: Bug
>          Components: MLlib, Spark Core
>            Reporter: Patrick Wendell
>            Assignee: Sean Owen
>            Priority: Critical
>
> The colt library we use is LGPL-licensed:
> http://acs.lbl.gov/ACSSoftware/colt/license.html
> We need to swap this out for commons-math. It is also a very old library that hasn't
been updated since 2004.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message