spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ibrahim yilmaz (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-12550) sbt-launch-lib.bash: line 72: 2404 Killed "$@"
Date Tue, 29 Dec 2015 08:30:50 GMT

    [ https://issues.apache.org/jira/browse/SPARK-12550?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15073638#comment-15073638
] 

ibrahim yilmaz commented on SPARK-12550:
----------------------------------------

root@ulakbus:~/spark# sbt/sbt assembly
NOTE: The sbt/sbt script has been relocated to build/sbt.
      Please update references to point to the new location.

      Invoking 'build/sbt assembly' now ...

Attempting to fetch sbt
Launching sbt from build/sbt-launch-0.13.7.jar
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=512m; support was removed
in 8.0
[info] Loading project definition from /root/spark/project/project
[info] Updating {file:/root/spark/project/project/}spark-build-build...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Compiling 1 Scala source to /root/spark/project/project/target/scala-2.10/sbt-0.13/classes...
[warn] there were 1 deprecation warning(s); re-run with -deprecation for details
[warn] one warning found
[info] Loading project definition from /root/.sbt/0.13/staging/ad8e8574a5bcb2d22d23/sbt-pom-reader/project
[warn] Multiple resolvers having different access mechanism configured with same name 'sbt-plugin-releases'.
To avoid conflict, Remove duplicate project resolvers (`resolvers`) or rename publishing resolver
(`publishTo`).
[info] Updating {file:/root/.sbt/0.13/staging/ad8e8574a5bcb2d22d23/sbt-pom-reader/project/}sbt-pom-reader-build...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.typesafe.sbt:sbt-git:0.6.1 -> 0.6.2
[warn] 	* com.typesafe.sbt:sbt-site:0.7.0 -> 0.7.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Compiling 1 Scala source to /root/.sbt/0.13/staging/ad8e8574a5bcb2d22d23/sbt-pom-reader/project/target/scala-2.10/sbt-0.13/classes...
[info] Loading project definition from /root/spark/project
[info] Updating {https://github.com/ScrapCodes/sbt-pom-reader.git#ignore_artifact_id}sbt-pom-reader...
[info] Resolving org.scala-sbt#sbt-launch;0.13.7 ...
[info] Done updating.
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* org.apache.maven.wagon:wagon-provider-api:1.0-beta-6 -> 2.2
[warn] Run 'evicted' to see detailed eviction warnings
[info] Updating {file:/root/spark/project/}plugins...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Compiling 9 Scala sources to /root/.sbt/0.13/staging/ad8e8574a5bcb2d22d23/sbt-pom-reader/target/scala-2.10/sbt-0.13/classes...
[warn] there were 1 deprecation warning(s); re-run with -deprecation for details
[warn] one warning found
[info] Compiling 3 Scala sources to /root/spark/project/target/scala-2.10/sbt-0.13/classes...
[warn] there were 1 deprecation warning(s); re-run with -deprecation for details
[warn] one warning found
[info] Set current project to spark-parent (in build file:/root/spark/)
[info] Updating {file:/root/spark/}launcher...
[info] Updating {file:/root/spark/}network-common...
[info] Resolving org.scala-lang#scala-library;2.10.4 ...
[info] Done updating.
[info] Resolving junit#junit;4.10 ...
[info] Updating {file:/root/spark/}streaming-flume-sink...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Updating {file:/root/spark/}unsafe...
[info] Resolving com.twitter#chill_2.10;0.5.0 ...
[info] Updating {file:/root/spark/}network-shuffle...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Updating {file:/root/spark/}core...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.code.findbugs:jsr305:1.3.9 -> 2.0.1
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] 	* commons-net:commons-net:2.2 -> 3.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Updating {file:/root/spark/}catalyst...
[info] Updating {file:/root/spark/}streaming...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving commons-codec#commons-codec;1.4 ...
[info] Updating {file:/root/spark/}graphx...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving org.objenesis#objenesis;1.2 ...
[info] Updating {file:/root/spark/}bagel...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving com.twitter#chill_2.10;0.5.0 ...
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Resolving org.codehaus.jackson#jackson-core-asl;1.9.13 ...
[info] Updating {file:/root/spark/}sql...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving com.thoughtworks.paranamer#paranamer;2.3 ...
[info] Updating {file:/root/spark/}streaming-flume...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving org.tukaani#xz;1.0 ...
[info] Updating {file:/root/spark/}streaming-mqtt...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving org.codehaus.jackson#jackson-mapper-asl;1.9.13 ...
[info] Updating {file:/root/spark/}streaming-kafka...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving org.codehaus.jackson#jackson-core-asl;1.9.13 ...
[info] Updating {file:/root/spark/}streaming-zeromq...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving org.apache.avro#avro-mapred;1.7.7 ...
[info] Updating {file:/root/spark/}streaming-twitter...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving org.apache.avro#avro-mapred;1.7.7 ...
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Resolving org.apache.avro#avro;1.7.7 ...
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[warn] There may be incompatibilities among your library dependencies.
[info] Resolving org.codehaus.jackson#jackson-core-asl;1.9.13 ...
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Resolving org.codehaus.jackson#jackson-mapper-asl;1.9.13 ...
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Resolving commons-beanutils#commons-beanutils-core;1.8.0 ...
[info] Updating {file:/root/spark/}mllib...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving org.codehaus.jackson#jackson-mapper-asl;1.9.13 ...
[info] Updating {file:/root/spark/}hive...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving org.codehaus.jackson#jackson-mapper-asl;1.9.13 ...
[info] Updating {file:/root/spark/}streaming-flume-assembly...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving com.twitter#chill-java;0.5.0 ...
[info] Updating {file:/root/spark/}streaming-mqtt-assembly...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving com.esotericsoftware.kryo#kryo;2.21 ...
[info] Updating {file:/root/spark/}streaming-kafka-assembly...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving com.twitter#chill-java;0.5.0 ...
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Resolving com.thoughtworks.paranamer#paranamer;2.3 ...
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Resolving org.xerial.snappy#snappy-java;1.0.5 ...
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.code.findbugs:jsr305:1.3.9 -> 2.0.1
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Resolving org.tukaani#xz;1.0 ...
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* commons-net:commons-net:2.2 -> 3.1
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[warn] There may be incompatibilities among your library dependencies.
[warn] Here are some of the libraries that were evicted:
[warn] 	* com.google.guava:guava:11.0.2 -> 14.0.1
[warn] Run 'evicted' to see detailed eviction warnings
[info] Resolving commons-beanutils#commons-beanutils;1.7.0 ...
[info] Updating {file:/root/spark/}repl...
[info] Resolving org.fusesource.jansi#jansi;1.4 ...
[info] Done updating.
[info] Resolving com.twitter#chill-java;0.5.0 ...
[info] Updating {file:/root/spark/}examples...
[info] Resolving org.apache.hadoop#hadoop-yarn-server-nodemanager;2.2.0 ...
/root/spark/build/sbt-launch-lib.bash: line 72:  2404 Killed                  "$@"

> sbt-launch-lib.bash: line 72:  2404 Killed "$@"
> -----------------------------------------------
>
>                 Key: SPARK-12550
>                 URL: https://issues.apache.org/jira/browse/SPARK-12550
>             Project: Spark
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 1.5.2
>         Environment: Ubuntu 14.04.3 LTS
> Scala version 2.10.4
> java version "1.8.0_66"
> Java(TM) SE Runtime Environment (build 1.8.0_66-b17)
> Java HotSpot(TM) 64-Bit Server VM (build 25.66-b17, mixed mode)
>            Reporter: ibrahim yilmaz
>
> sbt-launch-lib.bash: line 72:  2404 Killed                  "$@"



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message