spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Miao Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-15439) Failed to run unit test in SparkR
Date Tue, 24 May 2016 23:31:12 GMT

    [ https://issues.apache.org/jira/browse/SPARK-15439?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15299143#comment-15299143
] 

Miao Wang commented on SPARK-15439:
-----------------------------------

[~felixcheung] For the test case below:

test_that("Check masked functions", {
  # Check that we are not masking any new function from base, stats, testthat unexpectedly
  masked <- conflicts(detail = TRUE)$`package:SparkR`
  expect_true("describe" %in% masked)  # only when with testthat..
  func <- lapply(masked, function(x) { capture.output(showMethods(x))[[1]] })
  funcSparkROrEmpty <- grepl("\\(package SparkR\\)$|^$", func)
  maskedBySparkR <- masked[funcSparkROrEmpty]
  namesOfMasked <- c("describe", "cov", "filter", "lag", "na.omit", "predict", "sd", "var",
                     "colnames", "colnames<-", "intersect", "rank", "rbind", "sample",
"subset",
                     "summary", "transform", "drop", "window", "as.data.frame",
                     "endsWith", "startsWith")

When I run it in local, it has "endsWith" and "startsWith". However, when I submit PR, Jekins
test doesn't include these two. 

I don't know what is the difference when running in local and running auto test. Can you help
checking it? Thanks!

> Failed to run unit test in SparkR
> ---------------------------------
>
>                 Key: SPARK-15439
>                 URL: https://issues.apache.org/jira/browse/SPARK-15439
>             Project: Spark
>          Issue Type: Bug
>          Components: SparkR
>    Affects Versions: 2.0.0
>            Reporter: Kai Jiang
>
> Failed to run ./R/run-tests.sh   around recent commit (May 19, 2016)
> It might be related to permission. It seems I used `sudo ./R/run-tests.sh` and it worked
sometimes. Without permission, maybe we couldn't access /tmp directory.  However, the SparkR
unit testing is still brittle.
> [error message|https://gist.github.com/vectorijk/71f4ff34e3d34a628b8a3013f0ca2aa2]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message