spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dongjoon Hyun (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-15584) Abstract duplicate code: "spark.sql.sources." properties
Date Fri, 27 May 2016 00:52:13 GMT

    [ https://issues.apache.org/jira/browse/SPARK-15584?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15303276#comment-15303276
] 

Dongjoon Hyun commented on SPARK-15584:
---------------------------------------

Oh, sure! Thank you!

> Abstract duplicate code: "spark.sql.sources." properties
> --------------------------------------------------------
>
>                 Key: SPARK-15584
>                 URL: https://issues.apache.org/jira/browse/SPARK-15584
>             Project: Spark
>          Issue Type: Improvement
>          Components: SQL
>    Affects Versions: 2.0.0
>            Reporter: Andrew Or
>            Priority: Minor
>
> Right now we have "spark.sql.sources.provider", "spark.sql.sources.numParts" etc. everywhere.
If we mistype something then things will silently fail. This is pretty brittle. It would better
if we have static variables that we can reuse.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message