spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Owen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-17669) Strange behavior using Datasets
Date Mon, 26 Sep 2016 21:06:20 GMT

    [ https://issues.apache.org/jira/browse/SPARK-17669?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15524166#comment-15524166
] 

Sean Owen commented on SPARK-17669:
-----------------------------------

It's hard to say what is going on without knowing what you're executing. Lots of things changed
in 2.0, and it's not inconceivable that some things actually go slower. 

> Strange behavior using Datasets
> -------------------------------
>
>                 Key: SPARK-17669
>                 URL: https://issues.apache.org/jira/browse/SPARK-17669
>             Project: Spark
>          Issue Type: Bug
>          Components: SQL, Web UI
>    Affects Versions: 2.0.0
>            Reporter: Miles Crawford
>
> I recently migrated my application to Spark 2.0, and everything worked well, except for
one function that uses "toDS" and the ML libraries.
> This stage used to complete in 15 minutes or so on 1.6.2, and now takes almost two hours.
> The UI shows very strange behavior - completed stages still being worked on, concurrent
work on tons of stages, including ones from downstream jobs:
> https://dl.dropboxusercontent.com/u/231152/spark.png
> The only source change I made was changing "toDF" to "toDS()" before handing my RDDs
to the ML libraries.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message