spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Apache Spark (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (SPARK-17769) Some FetchFailure refactoring in the DAGScheduler
Date Mon, 03 Oct 2016 19:00:22 GMT

     [ https://issues.apache.org/jira/browse/SPARK-17769?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Apache Spark reassigned SPARK-17769:
------------------------------------

    Assignee: Mark Hamstra  (was: Apache Spark)

> Some FetchFailure refactoring in the DAGScheduler
> -------------------------------------------------
>
>                 Key: SPARK-17769
>                 URL: https://issues.apache.org/jira/browse/SPARK-17769
>             Project: Spark
>          Issue Type: Improvement
>          Components: Scheduler
>            Reporter: Mark Hamstra
>            Assignee: Mark Hamstra
>            Priority: Minor
>
> SPARK-17644 opened up a discussion about further refactoring of the DAGScheduler's handling
of FetchFailure events.  These include:
> * rewriting code and comments to improve readability
> * doing fetchFailedAttemptIds.add(stageAttemptId) even when disallowStageRetryForTest
is true
> * issuing a ResubmitFailedStages event based on whether one is already enqueued for the
current failed stage, not any prior failed stage
> * logging the resubmission of all failed stages 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message