spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Jackson-core-asl conflict with Spark
Date Thu, 12 Mar 2015 17:22:27 GMT
Uthay:
You can run mvn dependency:tree command to find out the actual jackson-core-asl
your project needs.

FYI

On Thu, Mar 12, 2015 at 10:17 AM, Paul Brown <prb@mult.ifario.us> wrote:

>
> So... one solution would be to use a non-Jurassic version of Jackson.  2.6
> will drop before too long, and 3.0 is in longer-term planning.  The 1.x
> series is long deprecated.
>
> If you're genuinely stuck with something ancient, then you need to include
> the JAR that contains the class, and 1.9.13 does not.  Why do you think you
> need that particular version?
>
>
>
>
> —
> prb@mult.ifario.us | Multifarious, Inc. | http://mult.ifario.us/
>
> On Thu, Mar 12, 2015 at 9:58 AM, Uthayan Suthakar <
> uthayan.suthakar@gmail.com> wrote:
>
>> Hello Guys,
>>
>> I'm running into below error:
>>
>> Exception in thread "main" java.lang.NoClassDefFoundError:
>> org/codehaus/jackson/annotate/JsonClass
>>
>> I have created a uber jar with Jackson-core-asl.1.9.13 and passed it with
>> --jars configuration, but still getting errors. I searched on the net and
>> found a few suggestions, such as disabling "USE_ANNOTATIONS", still no joy.
>>
>> I tried disabling SQL module and recompiled Spark and installed the
>> custom library, yet no joy.
>>
>> I'm running out of ideas, could you please assist me with this issue?
>>
>> Many thanks.
>>
>>
>> Uthay.
>>
>>
>>
>
>

Mime
View raw message