spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Error Compiling Spark 1.4.1 w/ Scala 2.11 & Hive Support
Date Mon, 26 Oct 2015 14:05:53 GMT
Scala 2.11 is supported in 1.5.1 release:

http://search.maven.org/#search%7Cga%7C1%7Ca%3A%22spark-parent_2.11%22

Can you upgrade ?

Cheers

On Mon, Oct 26, 2015 at 6:01 AM, Bryan Jeffrey <bryan.jeffrey@gmail.com>
wrote:

> All,
>
> I'm seeing the following error compiling Spark 1.4.1 w/ Scala 2.11 & Hive
> support. Any ideas?
>
> mvn -Dhadoop.version=2.6.1 -Dscala-2.11 -DskipTests -Pyarn -Phive
> -Phive-thriftserver package
>
> [INFO] Spark Project Parent POM .......................... SUCCESS [4.124s]
> [INFO] Spark Launcher Project ............................ SUCCESS [9.001s]
> [INFO] Spark Project Networking .......................... SUCCESS [7.871s]
> [INFO] Spark Project Shuffle Streaming Service ........... SUCCESS [3.904s]
> [INFO] Spark Project Unsafe .............................. SUCCESS [3.095s]
> [INFO] Spark Project Core ................................ SUCCESS
> [24.768s]
> [INFO] Spark Project Bagel ............................... SUCCESS [2.029s]
> [INFO] Spark Project GraphX .............................. SUCCESS [4.057s]
> [INFO] Spark Project Streaming ........................... SUCCESS [9.774s]
> [INFO] Spark Project Catalyst ............................ SUCCESS [6.804s]
> [INFO] Spark Project SQL ................................. SUCCESS [9.606s]
> [INFO] Spark Project ML Library .......................... SUCCESS
> [10.872s]
> [INFO] Spark Project Tools ............................... SUCCESS [0.627s]
> [INFO] Spark Project Hive ................................ SUCCESS
> [13.463s]
> [INFO] Spark Project REPL ................................ SUCCESS [1.414s]
> [INFO] Spark Project YARN ................................ SUCCESS [2.433s]
> [INFO] Spark Project Hive Thrift Server .................. FAILURE [8.097s]
>
>
> [ERROR]
> /spark/spark-1.4.1.hive.bak/sql/hive-thriftserver/src/main/scala/org/apache/spark/sql/hive/thriftserver/SparkSQLCLIDriver.scala:25:
> object ConsoleReader is not a member of package jline
> [ERROR] import jline.{ConsoleReader, History}
> [ERROR]        ^
> [WARNING] Class jline.Completor not found - continuing with a stub.
> [WARNING] Class jline.ConsoleReader not found - continuing with a stub.
> [ERROR]
> /spark/spark-1.4.1.hive.bak/sql/hive-thriftserver/src/main/scala/org/apache/spark/sql/hive/thriftserver/SparkSQLCLIDriver.scala:171:
> not found: type ConsoleReader
> [ERROR]     val reader = new ConsoleReader()
> [ERROR]                      ^
> [ERROR] Class jline.Completor not found - continuing with a stub.
>

Mime
View raw message