spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <so...@cloudera.com>
Subject Re: Spark 2.0.0-preview ... problem with jackson core version
Date Sat, 02 Jul 2016 14:12:11 GMT
Ah, it looks like it was 2.5.3 as of 2.0.0-preview:

https://github.com/apache/spark/blob/2.0.0-preview/pom.xml#L164

but was updated to 2.6.5 soon after that, since it was 2.6.5 in 2.0.0-RC1:

https://github.com/apache/spark/blob/v2.0.0-rc1/pom.xml#L163

On Sat, Jul 2, 2016 at 3:04 PM, Paolo Patierno <ppatierno@live.com> wrote:
> This sounds strange to me because here :
>
> https://mvnrepository.com/artifact/org.apache.spark/spark-core_2.11/2.0.0-preview
>
> I see :
>
> com.fasterxml.jackson.module ยป jackson-module-scala_2.11        2.5.3
>
> So it seems that 2.0.0-preview is bringing jackson module scala 2.5.3 that
> is what I see.
>
>
>
>> From: sowen@cloudera.com
>> Date: Sat, 2 Jul 2016 14:32:58 +0100
>> Subject: Re: Spark 2.0.0-preview ... problem with jackson core version
>> To: ppatierno@live.com
>> CC: charles.allen@metamarkets.com; user@spark.apache.org
>
>>
>> This is something to do with your app. The version is 2.6.5 in master
>> and branch-2.0, and jackson-module-scala is managed to this version
>> along with all the other jackson artifacts.
>>
>> On Sat, Jul 2, 2016 at 1:35 PM, Paolo Patierno <ppatierno@live.com> wrote:
>> > What I see is the following ...
>> >
>> > - Working configuration
>> >
>> > Spark Version : "2.0.0-SNAPSHOT"
>> >
>> > The Vert.x library brings ...
>> > jackson-annotations:2.6.0
>> > jackson-core:2.6.1
>> > jackson-databind:2.6.1
>> >
>> > Spark brings
>> > jackson-annotations:2.6.5
>> > jackson-core:2.6.5
>> > jackson-databind:2.6.5
>> > jackson-module-scala_2.11: 2.6.5
>> >
>> > The runtime will use the latest version 2.6.5 and all works fine.
>> >
>> > - NOT Working configuration
>> >
>> > Spark Version : "2.0.0-preview"
>> >
>> > The Vert.x library brings ... (same dependencies as before)
>> > jackson-annotations:2.6.0
>> > jackson-core:2.6.1
>> > jackson-databind:2.6.1
>> >
>> > Spark brings
>> > jackson-module-scala_2.11: 2.5.3
>> >
>> > The module scale related to jackson is 2.5.3 ... seems not work with
>> > above
>> > 2.6.0/2.6.1 version ... so the exception.
>> >
>> >
>> >> From: sowen@cloudera.com
>> >> Date: Sat, 2 Jul 2016 08:34:45 +0100
>> >> Subject: Re: Spark 2.0.0-preview ... problem with jackson core version
>> >> To: charles.allen@metamarkets.com
>> >> CC: ppatierno@live.com; user@spark.apache.org
>> >
>> >>
>> >> mvn dependency:tree?
>> >>
>> >> On Sat, Jul 2, 2016 at 12:46 AM, Charles Allen
>> >> <charles.allen@metamarkets.com> wrote:
>> >> > I'm having the same difficulty porting
>> >> > https://github.com/metamx/druid-spark-batch/tree/spark2 over to
>> >> > spark2.x,
>> >> > where I have to go track down who is pulling in bad jackson versions.
>> >> >
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe e-mail: user-unsubscribe@spark.apache.org
>> >>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe e-mail: user-unsubscribe@spark.apache.org
>>

---------------------------------------------------------------------
To unsubscribe e-mail: user-unsubscribe@spark.apache.org


Mime
View raw message