spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@hortonworks.com>
Subject Re: Quick one... AWS SDK version?
Date Wed, 04 Oct 2017 14:17:04 GMT

On 3 Oct 2017, at 21:37, JG Perrin <jperrin@lumeris.com<mailto:jperrin@lumeris.com>>
wrote:

Sorry Steve – I may not have been very clear: thinking about aws-java-sdk-z.yy.xxx.jar.
To the best of my knowledge, none is bundled with Spark.


I know, but if you are talking to s3 via the s3a client, you will need the SDK version to
match the hadoop-aws JAR of the same version of Hadoop your JARs have. Similarly, if you were
using spark-kinesis, it needs to be in sync there.

From: Steve Loughran [mailto:stevel@hortonworks.com]
Sent: Tuesday, October 03, 2017 2:20 PM
To: JG Perrin <jperrin@lumeris.com<mailto:jperrin@lumeris.com>>
Cc: user@spark.apache.org<mailto:user@spark.apache.org>
Subject: Re: Quick one... AWS SDK version?


On 3 Oct 2017, at 02:28, JG Perrin <jperrin@lumeris.com<mailto:jperrin@lumeris.com>>
wrote:

Hey Sparkians,

What version of AWS Java SDK do you use with Spark 2.2? Do you stick with the Hadoop 2.7.3
libs?

You generally to have to stick with the version which hadoop was built with I'm afraid...very
brittle dependency.

Mime
View raw message