spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shubham Chaurasia <shubh.chaura...@gmail.com>
Subject Target java version not set when building spark with tags/v2.4.0-rc2
Date Mon, 08 Oct 2018 05:45:35 GMT
Hi All,

I built spark with *tags/v2.4.0-rc2* using
./build/mvn -DskipTests -Phadoop-2.7  -Dhadoop.version=3.1.0 clean install

Now from spark-shell when ever I call any static method residing in an
interface, it shows me error like :
<console>:28: error: Static methods in interface require -target:jvm-1.8

However spark shell is getting correct java version, I verified like:

scala> java.lang.System.getProperty("java.version")
res1: String = 1.8.0_181

This was not the case when I was building with tags/v2.3.2

Have I missed something?

Thanks,
Shubham

Mime
View raw message