spark-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bsikander <behro...@gmail.com>
Subject Re: Spark 2.4.4 with Hadoop 3.2.0
Date Tue, 26 Nov 2019 09:24:40 GMT
It could be that CDH6 has the integration but somehow I am getting the
following very frequently while building Spark2.4.4 with Hadoop 3.2.0 and
running spark tests.

caused by: java.lang.IllegalArgumentException: Unrecognized Hadoop major
version number: 3.2.0
    at
org.apache.hadoop.hive.shims.ShimLoader.getMajorVersion(ShimLoader.java:174)
    at
org.apache.hadoop.hive.shims.ShimLoader.loadShims(ShimLoader.java:139)
    at
org.apache.hadoop.hive.shims.ShimLoader.getHadoopShims(ShimLoader.java:100)
    at
org.apache.hadoop.hive.conf.HiveConf$ConfVars.<clinit>(HiveConf.java:368)





--
Sent from: http://apache-spark-user-list.1001560.n3.nabble.com/

---------------------------------------------------------------------
To unsubscribe e-mail: user-unsubscribe@spark.apache.org


Mime
View raw message