spot-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Terry Healy <the...@bnl.gov>
Subject SPOT-ML Build failure
Date Mon, 11 Sep 2017 19:36:54 GMT
Hello-

I'm trying to build the 1.0 version of SPOT-ML on a new system. I'm using Scala version 2.11.8
on CentOS Linux 7.2. I have tried several
suggestions for this missing item from StackOverflow, but none seem to change the outcome.
In the error below, I see a reference to
scalaVersion 2.12 which I do not understand, nor can I find a reference to it in the build
or plugin files.

Any suggestions appreciated.


Thanks


[warn] 	::::::::::::::::::::::::::::::::::::::::::::::
[warn] 	::          UNRESOLVED DEPENDENCIES         ::
[warn] 	::::::::::::::::::::::::::::::::::::::::::::::
[warn] 	:: com.eed3si9n#sbt-assembly;0.9.1: not found
[warn] 	::::::::::::::::::::::::::::::::::::::::::::::
[warn]
[warn] 	Note: Some unresolved dependencies have extra attributes.  Check that these dependencies
exist with the requested attributes.
[warn] 		com.eed3si9n:sbt-assembly:0.9.1 (scalaVersion=2.12, sbtVersion=1.0)
[warn]
[warn] 	Note: Unresolved dependencies path:
[warn] 		com.eed3si9n:sbt-assembly:0.9.1 (scalaVersion=2.12, sbtVersion=1.0) (/home/spot/apache-spot-1.0-incubating/spot-ml/project/plugins.sbt#L18-19)
[warn] 		  +- default:spot-ml-build:0.1-SNAPSHOT (scalaVersion=2.12, sbtVersion=1.0)
[error] sbt.librarymanagement.ResolveException: unresolved dependency: com.eed3si9n#sbt-assembly;0.9.1:
not found
[error] 	at sbt.internal.librarymanagement.IvyActions$.resolveAndRetrieve(IvyActions.scala:331)
[error] 	at sbt.internal.librarymanagement.IvyActions$.$anonfun$updateEither$1(IvyActions.scala:205)
[error] 	at sbt.internal.librarymanagement.IvySbt$Module.$anonfun$withModule$1(Ivy.scala:229)


Mime
View raw message