sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Jarcec Cecho (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-526) Unable to resolve maven-scm-providers-standard
Date Tue, 31 Jul 2012 16:29:34 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-526?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13425898#comment-13425898
] 

Jarek Jarcec Cecho commented on SQOOP-526:
------------------------------------------

I've tried to investigate this and it appears to me that the code is trying to work with pom
file as it was jar (it's trying to open zip file to get the resources). I was not able to
find precise piece of code to fix this.

However I believe that it's not a blocker for upcoming 1.4.2 release.

Jarcec
                
> Unable to resolve maven-scm-providers-standard
> ----------------------------------------------
>
>                 Key: SQOOP-526
>                 URL: https://issues.apache.org/jira/browse/SQOOP-526
>             Project: Sqoop
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 1.4.1-incubating
>         Environment: ubuntu 11
>            Reporter: Rajesh Koilpillai
>            Priority: Trivial
>
> Not sure why it is unable to resolve this POM while running "ant test", tried removing
the folder and re-tried but it didn't seem to make any difference.
> Unable to obtain resource from /home/rajesh/.ivy2/cache/org.apache.maven.scm/maven-scm-providers-standard/poms/maven-scm-providers-standard-1.6.pom:
java.util.zip.ZipException: error in opening zip file
>     [junit] Unable to obtain resource from /home/rajesh/.ivy2/cache/org.apache.maven.scm/maven-scm-providers-standard/poms/maven-scm-providers-standard-1.6.pom:

>     [junit] java.util.zip.ZipException: error in opening zip file
>     [junit]  at java.util.zip.ZipFile.open(Native Method)
>     [junit]  at java.util.zip.ZipFile.<init>(ZipFile.java:127)
>     [junit]  at java.util.jar.JarFile.<init>(JarFile.java:135)
>     [junit]  at java.util.jar.JarFile.<init>(JarFile.java:99)
>     [junit]  at org.apache.tools.ant.AntClassLoader.getResourceURL(AntClassLoader.java:1002)
>     [junit]  at org.apache.tools.ant.AntClassLoader$ResourceEnumeration.findNextResource(AntClassLoader.java:145)
>     [junit]  at org.apache.tools.ant.AntClassLoader$ResourceEnumeration.<init>(AntClassLoader.java:109)
>     [junit]  at org.apache.tools.ant.AntClassLoader.findResources(AntClassLoader.java:949)
>     [junit]  at org.apache.tools.ant.AntClassLoader.getNamedResources(AntClassLoader.java:918)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message