sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cheolsoo Park (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SQOOP-571) Revert SQOOP-519 and SQOOP-524
Date Sun, 12 Aug 2012 22:13:38 GMT

     [ https://issues.apache.org/jira/browse/SQOOP-571?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Cheolsoo Park updated SQOOP-571:
--------------------------------

    Attachment: SQOOP-571.patch
    
> Revert SQOOP-519 and SQOOP-524
> ------------------------------
>
>                 Key: SQOOP-571
>                 URL: https://issues.apache.org/jira/browse/SQOOP-571
>             Project: Sqoop
>          Issue Type: Bug
>            Reporter: Cheolsoo Park
>            Assignee: Cheolsoo Park
>            Priority: Critical
>             Fix For: 1.4.2
>
>         Attachments: SQOOP-571.patch
>
>
> This is a regression from "SQOOP-519: Update the version of hsqldb decadency to 2.x".
Even though we set HADOOP_USER_CLASSPATH_FIRST in sqoop-configure.sh as discussed in SQOOP-524,
tasks still pick up Hsqldb-1.8.x that is present in classpath.
> {code}
> 12/08/10 11:54:28 INFO mapred.JobClient: Task Id : attempt_201208101150_0001_m_000000_0,
Status : FAILED
> Error: org.hsqldb.DatabaseURL.parseURL(Ljava/lang/String;ZZ)Lorg/hsqldb/persist/HsqlProperties;
> 12/08/10 11:54:32 INFO mapred.JobClient: Task Id : attempt_201208101150_0001_m_000000_1,
Status : FAILED
> Error: org.hsqldb.DatabaseURL.parseURL(Ljava/lang/String;ZZ)Lorg/hsqldb/persist/HsqlProperties;
> 12/08/10 11:54:35 INFO mapred.JobClient: Task Id : attempt_201208101150_0001_m_000000_2,
Status : FAILED
> Error: org.hsqldb.DatabaseURL.parseURL(Ljava/lang/String;ZZ)Lorg/hsqldb/persist/HsqlProperties;
> 12/08/10 11:54:39 INFO mapred.JobClient: Job complete: job_201208101150_0001
> {code}
> Hadoop 2.0 moved the hsqldb-2.x jar out of Hadoop classpath. (Please see MAPREDUCE-4498
for details.) So we no longer have the hsqldb-2.x jar in Hadoop classpath, and upgrading to
hsqldb-2.x is no longer needed at all. So I suggest that we should revert SQOOP-519 and SQOOP-524
to avoid any potential issues due to conflicting hsqldb jars in classpath.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message