sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cheolsoo Park (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SQOOP-536) Blob import doesn't work with avro 1.7.1
Date Fri, 03 Aug 2012 06:44:02 GMT
Cheolsoo Park created SQOOP-536:
-----------------------------------

             Summary: Blob import doesn't work with avro 1.7.1
                 Key: SQOOP-536
                 URL: https://issues.apache.org/jira/browse/SQOOP-536
             Project: Sqoop
          Issue Type: Bug
    Affects Versions: 1.4.1-incubating
            Reporter: Cheolsoo Park
            Assignee: Cheolsoo Park
             Fix For: 1.4.2


I see the following test failures when updating avro dependency from 1.5.3 to 1.7.1:

- MySQLLobAvroImportTest
- OracleLobAvroImportTest

The reason is because byte[] fails to be mapped to avro bytes type (see below the isBytes()
method of GenericData in avro 1.7.1). 
{code}
/** Called by the default implementation of {@link #instanceOf}.*/
protected boolean isBytes(Object datum) {
  return datum instanceof ByteBuffer;
}
{code}

The fix is to wrap byte[] as ByteWrapper so that avro GenericData can map it to bytes type.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message