sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cheolsoo Park" <cheol...@cloudera.com>
Subject Re: Review Request: SQOOP-599: Import to HBase is not working on secure cluster
Date Thu, 13 Sep 2012 18:07:29 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/7011/#review11481
-----------------------------------------------------------

Ship it!


Ship It!

- Cheolsoo Park


On Sept. 11, 2012, 9:33 a.m., Jarek Cecho wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/7011/
> -----------------------------------------------------------
> 
> (Updated Sept. 11, 2012, 9:33 a.m.)
> 
> 
> Review request for Sqoop.
> 
> 
> Description
> -------
> 
> I've added code that is putting HBase delegation token to mapreduce job.
> 
> Unfortunately we're currently still supporting HBase 0.90 that do not have security patches
and that is missing required method "obtainAuthTokenForJob". I've used reflection to get the
method or ignore state when it's missing.
> 
> 
> This addresses bug SQOOP-599.
>     https://issues.apache.org/jira/browse/SQOOP-599
> 
> 
> Diffs
> -----
> 
>   build.xml edcda6e 
>   src/java/org/apache/sqoop/mapreduce/HBaseImportJob.java 6a784d2 
> 
> Diff: https://reviews.apache.org/r/7011/diff/
> 
> 
> Testing
> -------
> 
> * ant test -Dhadoopversion={20,100,23,200}
> * Manual tests on secure hadoop cluster
> 
> 
> Thanks,
> 
> Jarek Cecho
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message