sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathleen Ting" <kathl...@apache.org>
Subject Re: Review Request: SQOOP-1002 Sqoop2: Mapreduce local mode detection is not working correctly on Hadoop 2.x
Date Sun, 12 May 2013 01:23:27 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/10687/#review20450
-----------------------------------------------------------

Ship it!


Ship It!

- Kathleen Ting


On April 20, 2013, 11:15 p.m., Jarek Cecho wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/10687/
> -----------------------------------------------------------
> 
> (Updated April 20, 2013, 11:15 p.m.)
> 
> 
> Review request for Sqoop.
> 
> 
> Description
> -------
> 
> I've added framework detection. If it is set to "yarn" then we can't be running in mapreduce
local mode.
> 
> 
> This addresses bug SQOOP-1002.
>     https://issues.apache.org/jira/browse/SQOOP-1002
> 
> 
> Diffs
> -----
> 
>   submission/mapreduce/src/main/java/org/apache/sqoop/submission/mapreduce/MapreduceSubmissionEngine.java
6607885ac609f49a0dd67440de64b6f18d4910f6 
> 
> Diff: https://reviews.apache.org/r/10687/diff/
> 
> 
> Testing
> -------
> 
> Unit and integration tests seems to be passing. In addition I've verified the functionality
on real Hadoop 2.x cluster.
> 
> 
> Thanks,
> 
> Jarek Cecho
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message