sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Veena Basavaraj (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SQOOP-1557) Sqoop2: SQ_CONFIGURABLE ( for entities who own configs)
Date Mon, 20 Oct 2014 13:56:34 GMT

     [ https://issues.apache.org/jira/browse/SQOOP-1557?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Veena Basavaraj updated SQOOP-1557:
-----------------------------------
    Description: 
SQ_CONNECTOR -> will be now call SQ_CONFIGURABLE ( it is basically a table to hold entities
that will specify configs)

Add another field to it, that is CONFIGURABLE_TYPE ( it can be connector or driver at this
point ). we can have a standard id for  Driver that we will use in the SQOOP, having nulls
to represent things is not clean since "none/null" can mean different things at different
contexts

Most importantly, not to have NULLs representing one too many things!!
 

Next,

We propose to split up the SQ_FORM ( which is the SQ_CONFIG after 1498) to SQ_JOB_CONFIG and
SQ_LINK_CONFIG ( it will parallel the SQ_JOB_INPUT and SQ_LINK_INPUT)

Direction is only relevant to job config ( and henceforth the job inputs). So we will store
the DIRECTION field in JOB_CONFIG.

If we want to have SQ_CONFIG, we can have it with the SQ_CFG_TYPE and then it will have  FK
on the SQ_CONFIGURABLE, so we know which entity owns this config easily. 

We can then have SQ_JOB_CONFIG and SQ_LINK_CONFIG have a FK on SQ_CONFIG.

Alternatively, dont have SQ_CONFIG, and just have SQ_JOB_CONFIG and SQ_LINK_CONFIG and have
a FK directly to SQ_CONFIGURABLE, both will have the CONFIG_NAME and INDEX fields.

Last,

MIsc cleanup/ renames / documentation  of the repository schema query names for clarity and
consistency. Especially the create schema / upgrade schema and then CRUD queries are groupes
apts.



  was:

SQ_CONNECTOR -> will be now call SQ_CONFIGURABLE ( it is basically a table to hold entities
that will specify configs)

Add another field to it, that is CONFIGURABLE_TYPE ( it can be connector or driver at this
point ). we can have a standard id for  Driver that we will use in the SQOOP, having nulls
to represent things is not clean since "none/null" can mean different things at different
contexts

Most importantly, not to have NULLs representing one too many things!!
 

Next,

We propose to split up the SQ_FORM ( which is the SQ_CONFIG after 1498) to SQ_JOB_CONFIG and
SQ_LINK_CONFIG ( it will parallel the SQ_JOB_INPUT and SQ_LINK_INPUT)

Direction is only relevant to job config ( and henceforth the job inputs). So we will store
the DIRECTION field in JOB_CONFIG.

If we want to have SQ_CONFIG, we can have it with the SQ_CFG_TYPE and then it will have  FK
on the SQ_CONFIGURABLE, so we know which entity owns this config easily. 

We can then have SQ_JOB_CONFIG and SQ_LINK_CONFIG have a FK on SQ_CONFIG.

Alternatively, dont have SQ_CONFIG, and just have SQ_JOB_CONFIG and SQ_LINK_CONFIG and have
a FK directly to SQ_CONFIGURABLE, both will have the CONFIG_NAME and INDEX fields.




> Sqoop2: SQ_CONFIGURABLE ( for entities who own configs) 
> --------------------------------------------------------
>
>                 Key: SQOOP-1557
>                 URL: https://issues.apache.org/jira/browse/SQOOP-1557
>             Project: Sqoop
>          Issue Type: Improvement
>            Reporter: Veena Basavaraj
>            Assignee: Veena Basavaraj
>
> SQ_CONNECTOR -> will be now call SQ_CONFIGURABLE ( it is basically a table to hold
entities that will specify configs)
> Add another field to it, that is CONFIGURABLE_TYPE ( it can be connector or driver at
this point ). we can have a standard id for  Driver that we will use in the SQOOP, having
nulls to represent things is not clean since "none/null" can mean different things at different
contexts
> Most importantly, not to have NULLs representing one too many things!!
>  
> Next,
> We propose to split up the SQ_FORM ( which is the SQ_CONFIG after 1498) to SQ_JOB_CONFIG
and SQ_LINK_CONFIG ( it will parallel the SQ_JOB_INPUT and SQ_LINK_INPUT)
> Direction is only relevant to job config ( and henceforth the job inputs). So we will
store the DIRECTION field in JOB_CONFIG.
> If we want to have SQ_CONFIG, we can have it with the SQ_CFG_TYPE and then it will have
 FK on the SQ_CONFIGURABLE, so we know which entity owns this config easily. 
> We can then have SQ_JOB_CONFIG and SQ_LINK_CONFIG have a FK on SQ_CONFIG.
> Alternatively, dont have SQ_CONFIG, and just have SQ_JOB_CONFIG and SQ_LINK_CONFIG and
have a FK directly to SQ_CONFIGURABLE, both will have the CONFIG_NAME and INDEX fields.
> Last,
> MIsc cleanup/ renames / documentation  of the repository schema query names for clarity
and consistency. Especially the create schema / upgrade schema and then CRUD queries are groupes
apts.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message