sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abraham Elmahrek (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-1651) Sqoop2: Cleanup: Naming and ordering of methods in Repo relates classes
Date Sun, 02 Nov 2014 17:53:34 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-1651?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14193936#comment-14193936
] 

Abraham Elmahrek commented on SQOOP-1651:
-----------------------------------------

+1 committed. Thanks [~vybs]!

> Sqoop2: Cleanup: Naming and ordering of methods in Repo relates classes
> -----------------------------------------------------------------------
>
>                 Key: SQOOP-1651
>                 URL: https://issues.apache.org/jira/browse/SQOOP-1651
>             Project: Sqoop
>          Issue Type: Sub-task
>            Reporter: Veena Basavaraj
>            Assignee: Veena Basavaraj
>             Fix For: 2.0.0
>
>         Attachments: SQOOP-1651.patch
>
>
> this RB has 2 changes.
> for clarity in reading ( and forward thinking to separate the repo apis per entity so
multiple repo support becomes easier) I group the link related and job related methods together
> Second, all the methods have the verb and then the noun convention.
> Except the 2 methods I have renamed them to be consistent, so it is clear than when a
new methods is added we do not fight over naming conventions. Going forward we will document
the coding guidelines for the sqoop code



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message