sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Jarcec Cecho (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-1911) Sqoop2: Derby1_99_4UpgradeTest is constantly failing on pre-commit hook
Date Tue, 16 Dec 2014 17:27:13 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-1911?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14248531#comment-14248531
] 

Jarek Jarcec Cecho commented on SQOOP-1911:
-------------------------------------------

Closely looking into the logs, I've noticed that the upgrade procedure is not being run and
hence Sqoop server fails to start (that is expected). Looking into the code [SqoopMiniCluster|https://github.com/apache/sqoop/blob/sqoop2/test/src/main/java/org/apache/sqoop/test/minicluster/SqoopMiniCluster.java#L175]
is allowing upgrades whereas the overridden code in [DerbySqoopMiniCluster|https://github.com/apache/sqoop/blob/sqoop2/test/src/test/java/org/apache/sqoop/integration/repository/derby/upgrade/DerbyRepositoryUpgradeTest.java#L65]
is not. I believe that the code was passing before, because we did not needed the upgrade
procedure (the repo version was the same).

> Sqoop2: Derby1_99_4UpgradeTest is constantly failing on pre-commit hook
> -----------------------------------------------------------------------
>
>                 Key: SQOOP-1911
>                 URL: https://issues.apache.org/jira/browse/SQOOP-1911
>             Project: Sqoop
>          Issue Type: Bug
>    Affects Versions: 1.99.4
>            Reporter: Jarek Jarcec Cecho
>            Assignee: Jarek Jarcec Cecho
>             Fix For: 1.99.5
>
>
> It seems that {{Derby1_99_4UpgradeTest}} is constantly failing on pre-commit hook which
is causing unnecessary false alarms (for example SQOOP-1900). 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message