sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Jarcec Cecho (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-2544) Sqoop2: Drop connectors servlet
Date Thu, 24 Sep 2015 22:59:05 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-2544?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14907205#comment-14907205
] 

Jarek Jarcec Cecho commented on SQOOP-2544:
-------------------------------------------

Root cause of the failure is that we're running the build on slave without proper maven version:

{code}
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error resolving version for 'org.codehaus.mojo:findbugs-maven-plugin': Plugin requires
Maven version 3.0.1
{code}

I'll re-run the hook.

> Sqoop2: Drop connectors servlet
> -------------------------------
>
>                 Key: SQOOP-2544
>                 URL: https://issues.apache.org/jira/browse/SQOOP-2544
>             Project: Sqoop
>          Issue Type: Sub-task
>            Reporter: Jarek Jarcec Cecho
>            Assignee: Jarek Jarcec Cecho
>             Fix For: 1.99.7
>
>         Attachments: SQOOP-2544.patch, SQOOP-2544.patch, SQOOP-2544.patch, SQOOP-2544.patch
>
>
> If I'm looking correctly, then we have two servlets - one called {{Connectors}} and second
called {{Connector}} (plurality is the difference). Looking into the client code it seems
that we're not really using {{Connectors}} form anywhere as it's a functionality equivalent
for calling {{connector/all}}. Hence I would like to propose simply dropping it and have one
public interface less to worry about. Any objections?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message