sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-2819) Use connector name instead of id in Repository.findJobsForConnector methods
Date Sat, 06 Feb 2016 07:05:39 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-2819?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15135650#comment-15135650
] 

Hudson commented on SQOOP-2819:
-------------------------------

SUCCESS: Integrated in Sqoop2 #1010 (See [https://builds.apache.org/job/Sqoop2/1010/])
SQOOP-2819: Use connector name instead of id in (colin: [https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=e64598af413a2e5b4ff2d864c636c5bc9a04ad62])
* repository/repository-postgresql/src/test/java/org/apache/sqoop/integration/repository/postgresql/TestJobHandling.java
* core/src/test/java/org/apache/sqoop/repository/TestJdbcRepository.java
* repository/repository-derby/src/test/java/org/apache/sqoop/repository/derby/TestJobHandling.java
* repository/repository-common/src/main/java/org/apache/sqoop/repository/common/CommonRepositoryInsertUpdateDeleteSelectQuery.java
* core/src/main/java/org/apache/sqoop/repository/Repository.java
* core/src/main/java/org/apache/sqoop/repository/JdbcRepositoryHandler.java
* core/src/main/java/org/apache/sqoop/repository/JdbcRepository.java
* repository/repository-common/src/main/java/org/apache/sqoop/repository/common/CommonRepositoryHandler.java
* server/src/main/java/org/apache/sqoop/handler/JobRequestHandler.java
* repository/repository-mysql/src/test/java/org/apache/sqoop/integration/repository/mysql/TestJobHandling.java


> Use connector name instead of id in Repository.findJobsForConnector methods
> ---------------------------------------------------------------------------
>
>                 Key: SQOOP-2819
>                 URL: https://issues.apache.org/jira/browse/SQOOP-2819
>             Project: Sqoop
>          Issue Type: Bug
>            Reporter: Jarek Jarcec Cecho
>            Assignee: Jarek Jarcec Cecho
>             Fix For: 1.99.7
>
>         Attachments: SQOOP-2819.patch
>
>
> In SQOOP-2573 we've migrated {{Repository. findLinksForConnectorUpgrade}} and {{Repository.
findLinksForConnector}} to use name instead of id. it seems that we forgot to do the same
for {{Repository. findJobsForConnectorUpgrade}} and {{Repository. findJobsForConnector}} though.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message